E46 Fanatics Forum banner
1 - 20 of 52 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 · (Edited)
Background:
-guy backed into me with his SUV in a grocery store parking lot
-his insurance accepted liability and I took it to a reputable body shop in Seattle (I'm new to the area) to get body fixed
-car fix in about a week, body looks gorgeous but....

When I get the car back, the owner of the shop mentions to me that I should take the car on the highway for at least 15 minutes after picking it up. I ask why? He says they stopped and started the car a lot to take it short distances in the shop and this is bad for BMWs and Audis. He says this has happened before. I'm very skeptical but take it anyway. I hop in the car and drive it out, and I have an EXTREMELY rough idle, feeling like the car is going to stall and getting kicked back in the seat and no power at all from the accelerator. Additionally the SES light is on. :banghead: I'm terrified at this point but I go drive it on the highway for a bit. This helps slightly so I no longer feel like I'll stall, but the car still has a very rough idle and the SES light is on. I also have no power at all from the accelerator, feels like I have a lawnmower engine in there. I scan the problem codes and I have 9 of them :(

P0171 - Fuel trim bank one condition
P0174 - Fuel trim bank two condition
P0300 - Misfire detected, random cylinders (x2)
P0444 - Evap purge vent solenoid circuit condition
P1083 - Fuel control mixture lean bank 1 sensor 1
P1342 - Misfire during start cylinder 1
P1347 - Misfire cylinder 3 with fuel cut off
P1352 - Misfire during start cylinder 6

Holy sh** what the hell did they do to my car??? Exterior looks beautiful, but my car purred like a kitten before I took it to the shop and now it barely runs. I've been running it for a week hobbling around like this hoping it would go away like they said it would, and now I'm about to get in touch with the shop again. Help! Insurance said to talk to the shop and ask them to help me since they had it while this happened, but then what do I do? File a new claim? What is wrong with my car and what could have happened? Has anyone had an experience like this?
 

·
Registered
Joined
·
8 Posts
was the engine harness damaged or removed in the repair? if so maybe they left some ground disconnected or maybe they just left some item or items disconnected. I would take it back to them and have them worry about it though. I had a similiar issue when I wasn't happy with a repair after an accident that wasn't my fault. I was lucky and I had chose to take it to a shop that the insurance company had within network. So I called the at fault insurance co and told them how I wasn't happy and they told me they would get the body shop to contact me, sure enough that day I had the car back there. They had to repaint the whole job, they tried telling me spots in the paint were something I would have to deal with.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #4 · (Edited)
was the engine harness damaged or removed in the repair? if so maybe they left some ground disconnected or maybe they just left some item or items disconnected. I would take it back to them and have them worry about it though. I had a similiar issue when I wasn't happy with a repair after an accident that wasn't my fault. I was lucky and I had chose to take it to a shop that the insurance company had within network. So I called the at fault insurance co and told them how I wasn't happy and they told me they would get the body shop to contact me, sure enough that day I had the car back there. They had to repaint the whole job, they tried telling me spots in the paint were something I would have to deal with.
I don't think the engine harness was damaged or removed. The progressive lady told me to contact the shop and ask them to help me first. This sounds like a total nightmare.
 

·
Registered
Joined
·
8 Posts
I don't think the engine harness was damaged or removed. The progressive lady told me to contact the shop and ask them to help me first. This sounds like a total nightmare.
I wouldn't make it seem like much of a deal just take back to them and tell your **** isn't running right you think they left something disconnected or whatever let them deal with the nightmare end of it. Just tell them you contacted progressive and they told you to bring it back to them. They don't want to piss on progressive. Just play it cool and they can deal with it..
 

·
Registered
Joined
·
5,333 Posts
Did they do any work around the engine?
This may just be a coincidence. What's the mileage?
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #9 ·
did you look under the hood to see if everything appeared there and connected?
Yeah, everything looks pretty normal under the hood as far as I can tell and I spend a decent amount of time in there so I know what it looks like. Car is stuck in my underground parking garage and is stalling. Urghhh guess I can kiss getting to work tomorrow goodbye
 

·
Registered
Joined
·
8 Posts
Yeah, everything looks pretty normal under the hood as far as I can tell and I spend a decent amount of time in there so I know what it looks like. Car is stuck in my underground parking garage and is stalling. Urghhh guess I can kiss getting to work tomorrow goodbye
i'd call the bodyshop and tell them they need to tow that thing in explain problems tell them even if it did run it would seem unsafe to try to get it in to them. This is only assuming your car was in good running order b4 it went in.
 

·
Registered
Joined
·
129 Posts
1) Give us before and after pictures. We cna judge by what they did on the outside to see what they may have had to remove to do it.
2) Why did you wait so long? As soon as you drove off and experienced problems you should've turned right back around and took it back.
3) That sucks.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #14 ·
i'd call the bodyshop and tell them they need to tow that thing in explain problems tell them even if it did run it would seem unsafe to try to get it in to them. This is only assuming your car was in good running order b4 it went in.
Perfect running condition before taking t in, just an ugly dent in the hood and smashed kidney grilles/corner lamp.

After pics are linked in my sig. Exterior looks great. Will take me a bit to upload the before.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #16 ·
1) Give us before and after pictures. We cna judge by what they did on the outside to see what they may have had to remove to do it.
2) Why did you wait so long? As soon as you drove off and experienced problems you should've turned right back around and took it back.
3) That sucks.
The body shop has a really good reputation and the owner is a nice guy so I was inclined to at least give it a week. Family owned shop. H&I automotive in Seattle. That said, first time they have done work on my car.
 

·
Registered
Joined
·
8 Posts
The body shop has a really good reputation and the owner is a nice guy so I was inclined to at least give it a week. Family owned shop. H&I automotive in Seattle. That said, first time they have done work on my car.
Just get it back to them, pump up the nice paint job and how you are pleased with that then detail the problems you have had since you left the shop and if its a good shop they will do what they can to get running right.
 
1 - 20 of 52 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top