BMW E46 Fanatics Forum banner

8181 - 8200 of 8226 Posts

·
Registered
Joined
·
178 Posts
Mine was a 2000 E46 330i 5 speed ZF manual and it definitely doesn't have a speed sensor on the box
Well i stand corrected and confused then lol, unless the 6 speeds use a gearbox sensor for the ecu and others dont I have no idea! However the throttle correction tables (ip_t_pvs_cor_r_X_npvscor) go by gear, so they won't function properly without any wheel speed input to the ecu so it might be worth zeroing those out and seeing if that helps at all?

Sent from my SM-G973F using Tapatalk
 

·
Registered
Joined
·
8 Posts
Well i stand corrected and confused then lol, unless the 6 speeds use a gearbox sensor for the ecu and others dont I have no idea! However the throttle correction tables (ip_t_pvs_cor_r_X_npvscor) go by gear, so they won't function properly without any wheel speed input to the ecu so it might be worth zeroing those out and seeing if that helps at all?

Sent from my SM-G973F using Tapatalk
Those tables have the same values for every gear even for neutral(ip_t_pvs_cor_r_0_npvscor), so I did try it, but I can do. Thanks!
 

·
Registered
Joined
·
8 Posts
Those tables have the same values for every gear even for neutral(ip_t_pvs_cor_r_0_npvscor), so I did try it, but I can do. Thanks!
I set all the tables to 0, but still no change. It seems to be more obvious in 5th gear after 3000 RPM. I can't feel it that much if I am in 4th gear over 3000 RPM. To be clear, the logs show 0 vehicle speed all the time, so the ECU must think it's in neutral all the time.
 

·
Registered
Joined
·
26 Posts
Guys, quick question, im having trouble activating ms4x flasher on Win 7...i generate the license, put it in the folder but it doesnt recognize it...anybody had this trouble before?
 

·
Registered
Joined
·
70 Posts

·
Registered
Joined
·
178 Posts
MS43 uses processed speed signal from ABS/DSC unit, I'm 100% sure. The gearbox sensor might be on older cars.
Turns out you're absolutely right about this, I disconnected one of my speed sensors as I've refitted my welded diff and the timered overrun and launch control speed parameters aren't functioning properly, so I would definitley check any throttle correction tables that have speed/gear parameters in them. And on a side note I'm still curious as to what the sensor in my gearbox is for

Sent from my SM-G973F using Tapatalk
 

·
Registered
1999r e46 328 m54b28,5T
Joined
·
1 Posts
I noticed that the injection time is shortened during the power cut, I do not know what it may be caused by, the gearbox has no errors.
the whole log, afr log video is here. I was able to turn on MAFMode?.
Maf rs4, 630cc, gt3530
Log, video, Bin ms42
912515
 

·
Registered
Joined
·
46 Posts
Having some trouble with lean spikes right when I give the car some gas, off idle, to get moving. Reviewed some logs and found that I'm getting some pretty big load spikes at 10-12% pedal input



Doesn't seem quite right to me. My idle/part load maps are within 5% as indicated by fuel trims (STFT and LTFT). Any suggestions would be appreciated, thanks!
were you ever able to sort this out? I have the same issue exactly. Been playing with enrichment tables and haven't fixed it yet. anything would be helpful
 

·
Registered
Joined
·
557 Posts
Does the engine hesitate or stumble? If not, don't worry about it. To stop it fully, you will see a large increase in fuel usage when in stop-go traffic. It happened to me and the benefit was nothing to feel. It is all to do with the lag of the air/fuel response in the engine and the sudden increase in air from a small throttle opening at idle.
 

·
Registered
Joined
·
18 Posts
Hi folk,

I just install a supercharger on my 330i with a calculating boost approx 10 psi, now I'm confused with the load filtration table and MAF to use. I guess that the current B30 MAF is fine for such a low boost like 10 psi but how I can deal with the load filtration table can anyone give me an example workaround for this table or bin file is very appreciate

Thanks in advance
 

·
Registered
Joined
·
46 Posts
Does the engine hesitate or stumble? If not, don't worry about it. To stop it fully, you will see a large increase in fuel usage when in stop-go traffic. It happened to me and the benefit was nothing to feel. It is all to do with the lag of the air/fuel response in the engine and the sudden increase in air from a small throttle opening at idle.
when shifting at lower rpm, when iat is cold, it cuts 100% for a split second and comes back. sometimes worse than others but its incredibly annoying.
 

·
Registered
Joined
·
18 Posts
Is there a certain range of pedal before the TB actually opens instead of the ICV operating? Trying to tune on the m50 manifold with the Porsche injectors with e-85. Wanted to know because it is cold again in illinois and adding fuel and ignition advance to keep car running on cold start is requiring pedal but logger does not report TB angle at 0. Thanks
 

·
Registered
Joined
·
588 Posts
Is there a certain range of pedal before the TB actually opens instead of the ICV operating? Trying to tune on the m50 manifold with the Porsche injectors with e-85. Wanted to know because it is cold again in illinois and adding fuel and ignition advance to keep car running on cold start is requiring pedal but logger does not report TB angle at 0. Thanks
Roughly 15% pedal position.


Sent from my iPhone using Tapatalk
 

·
Registered
2002 e46 320 sedan / sport package 2 / m54b22 / steptronic
Joined
·
133 Posts
infoboy

Just reset with inpa or manually there are many videos about it.
Or are you asking for something more complicated ?
 

·
Registered
Joined
·
403 Posts
infoboy

Just reset with inpa or manually there are many videos about it.
Or are you asking for something more complicated ?
Thanks for your reply. Im sick of resetting it everytime i just want to deactiavte it from the ecu, is there anyway to deactivate it using tuner pro or romraider?

Sent from my SM-J415F using Tapatalk
 
8181 - 8200 of 8226 Posts
Top