BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
is your best friend
Joined
·
732 Posts
Discussion Starter #1
man..wtf.. sometimes when i turn on my car..the battery light comes on... and goes off like the next day.. and sometimes..i cant even start my car..but if i keep trying..my car eventually will start.. does that mean my battery is low???? but i only had my car since march.
this problem has been happening for a couple months...but now.. its pretty normal again..just hope it doesnt happen again.
WHAT SHOULD I DO?!?! :dunno:
 

·
Legendary like a schoolboy
Joined
·
6,594 Posts
you leave any radar detector or anyother accesory in the cig outlet?? Or have like live wires (maybe from dde,illuminated shift knob,etc) touching the frame. My battery drained and made my car make clicking noises while starting. Bad habit i had leaving radar and ionizer on while the caar sleeps in da garage.
 

·
Registered
Joined
·
274 Posts
wow

mine is doing the exact same thing, as of 2 days ago...

SO, here's what i've done so far:

put a volt-level reader on it...generally speaking (don't know for BMWs) it should be about 14Volts or so in idle. mine was at about 12 at one point and wouldn't start. soo, i jump-started the car, held it at about 2300rpm for a few minutes and it was at about 13.1...i then let it idle for like 25 minutes and it went to about 13.3...it was fine driving for a little and then the light went on again.
i tightened the bolt on the battery in the trunk and it didn't change anything, so at this point I'm not sure what I'll do. the alternator seems to be fine (or somewhat) since the car is techincally charging, just running out of power really quickly.

anyone else have any idea about this? i really don't see any reason for a new battery, the car nearly 20,000 miles on it..!

if it's not the alternator or the battery itself, then the problem is way too deep in wiring for me to diagnose...

anyone else have this and figure what's wrong, take to the dealer, etc?
 

·
Registered
Joined
·
724 Posts
do your buttons on the auto climate control for the temp and fan speed go up and down? ex. not < > but ^ v? if so, then you need a new part..i dont know why this happens but it is something with the a/c module draining the battery...ask ur dealer about this
 

·
Registered
Joined
·
274 Posts
huntmdwn--you mean whether or not the physical button itself is a <> or a ^v "type" is what affects the draining of the battery?

because mine are <> and i have this battery issue, so you don't have the solution to my problem?! :ben:



not to mention, my battery indicator light went on when i was shifting (spiritedly) from 3rd to 4th at 80mph tonight on the highway--given that my alternator is working (at least somewhat) shouldn't this not happen considering the amount of charging that should be taking place?!?!

soo confused....
 

·
Registered
Joined
·
724 Posts
call your dealer and ask because mine kept draining the battery for some reason and a new small plug in piece needed to be changed..the dealer says this happens often so they stock up on this piece.
 
1 - 8 of 8 Posts
Top