E46 Fanatics Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
172 Posts
Discussion Starter · #1 · (Edited)
Auto Transmission Issue (Limp Home) - Another Update

Okay, it's been a few years since i posted about my transmission going into this mode called "Limp Home" http://forum.e46fanatics.com/showthread.php?t=337802&highlight=. A dash light comes on and RPM goes above 3000 and acceleration is sluggish from stop.

Many on the board and the dealer has said my 'tranny is toast.' Still not certain if it's the actual tranny or just a sensor as my indie mechanic confirms it shifts fine. Almost 4 years later i'm still dealing with this issue only now there is a new development.

This problem only starts when I hit 70 MPH. So when driving any speed less then it's fine. I noticed this after changing my driving patterns after gas price reached an all time high not too long ago. This use to occur on a daily/weekly basis. Now with driving less then 70 MPH it's been about 2 months and no light. What do you think?
 

·
Registered
Joined
·
172 Posts
Discussion Starter · #4 ·
Gear speed sensors? Problem with the transmission control module?

Software update (there have been more then 20 updates for the software in your transmission since it left the factory, some are rather important as well) and a fluid change will more then likely fix whatevers wrong, unless it really is a bad sensor..
How much do you think dealer charges for software updates? How do I know if i have the latest? I don't want to be charged by dealer just to have them look...:yikes:
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top