E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 15 of 15 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter · #1 ·
I've searched the archives, and found only two SB's dealing with bad AM reception...both deal with the amp in the C-pillar. Has anyone had anything done about bad AM recently?? I'm taking in to dealer in 2 hours and want some back-up. Any new SB's about replacing radio, etc?? Help!
 

·
Registered
Joined
·
20 Posts
The only thing new is that the am reception still sucks....it's hard to imagine that cars costing as much as these can't have a radio at least as decent as a bottom- of- the- line Toyota.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #4 ·
Howling is closer to what my AM is doing...mine is now at the dealer. My loaner '03 325i AM works fine!!! I gave the service rep the SR's I knew of...mostly they say to check or replace the antenna amp in the C-pillar. I called back and suggested changing the radio, since the new one in my loaner seems to work!
 

·
Registered
Joined
·
2,120 Posts
people still listen to AM? I haven't even heard FM in like a year since satt. radio came out. AM is just a week signal, it's bad, and it will get worse as years go on. the facotry ant in the rear glass leaves a lot to be desired. remember the cars from back in the 60's that had AM radio's and ant's that stuck up 4 feet in the air? they were like that for a reason. put one of those on your fender & I guarantee you'll pick up AM great then!!!!!!!!!!!
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #6 ·
Nice slam, but not helpful. Answers like that, I expect in the E46 Lounge, but not here.

There are owners out there who actually enjoy news, weather, and traffic occasionally while driving. The line about AM being old is wearing thin. NONE of my other cars have this problem. BMW has no excuse. I shouldn't have to get XM to get traffic in a BMW.
 

·
Registered
Joined
·
553 Posts
Agree on the unhelpful responses

I travel a lot and need AM for weather, road conditions and actually staying in touch with the world through news/talk, so please no more trash talk about AM. And there is not such thing as AM signals getting weaker.
Now, to get back to the real question, does anyone have any real information of experience on the AM radio problem? My dealer insisted the problem was because of window tinting, but it has been weak before that.
 

·
Registered
Joined
·
79 Posts
I have had a 2K2 330I for a year and a half now and my AM was always clear as a bell. Now two months ago out of the blue I turn on the local sports radio show and there is this crappy static all over the band. Sometimes it is clear but most of the time it is now Sh..t. The dealer told me that this is happening a lot and they are replacing the AM amplifier because of a bad circuit. I am going to have this done next time I go in for service. FM is fine and I only listen to AM once and a while.
 

·
Registered
Joined
·
120 Posts
Discussion Starter · #9 ·
Dealer replaced the antenna amp...reception is marginally better, but still not as good as the 03 325i loaner I had. My car is a 01 325i...:thumbdwn:
 

·
Registered
Joined
·
2,120 Posts
yes am is getting worse. the air is so full of invisible RF waves that if they were colored we could stand 3' away and not be able to see each other. cell phones are a HUGE cause for this, as is anything that emits an RF signal. AM, yes, is greatly affected by this RF interferance in the air, & as it get's worse, which it does by the day, AM will get worse. get used to it.
PS: My Alpine picks it up great, much better than factory, but then it was turned off, never to be turned on again...
 

·
unregistered user
Joined
·
793 Posts
AM reception is good on my stock stereo- as a matter of fact I was listening to it today to get news about the current middle east situation. I think it probably has more to do with your geographical location (hills, proximity to powerlines, etc) and other sources of RF interference than it does with a crappy bmw radio. Or maybe then I lucked out and ended up with a good unit. who knows?
 

·
Registered
Joined
·
9 Posts
mine works fine most of the time I did notice an issue when my cell phone charger was plugged in the AM sucked diconnected it and the issue was resolved.
 

·
Registered
Joined
·
1 Posts
I had this problem for the longest time. I asked the dealer to fix it three times quoting the TSB #'s. Finally, on the third time, they fixed it and the problem is gone.

It was a really annoying generator whine. Now the problem is gone and the AM reception is lot better.
 

·
Owner
Joined
·
3,747 Posts
I noticed radio reception gets worse if you turn on other electrical equipment in your car like A/C, headlights, etc. If you turn off all your electrical stuff, then the radio gets good reception. Looks like BMW is not using high quality wires and interconnects in their stereos.
 

·
Registered
Joined
·
650 Posts
When I programmed a mute button into my radio, I lost almost all my AM reception.

Try playing with this:

RE: "MUTE" control function

I do believe from my research and trials that this info only applies to those of you who have the HK BMW Business in dash CD head unit.

If your radio head unit has a button on the right side of the station presets that has a printed "PTY and "RDS" on it this info is most likely useless.

If your radio head unit has a button on the right side of the station presets that has 2 horizontal slashes ( - - ), and a small display above that button seperate from the main dislay, then this info should work for you.

The reason for this seems to be that the slashes indicate variable/choosable functions for these button positions. Obviously, the printed ones have pre-determined functions only (PTY/RDS)

1) turn the radio off
2) turn it back on again & dont touch any buttons
3) hold down the 'M' on the right for 10 seconds, this will bring up the radio head serial #
4) depress the '+' key on the left under the volume knob 6 times until the word "AREA" displays it should say USA next to it
5) now depress the position #1 preset button until the words "AREA OC+RDS appear
6) turn the radio off and your new choices will be set

There is a small display to the right of the large display which originally should have displayed RDS*PTY
When your thru with this reset, it should display RDS*MUTE

When you press the slash under MUTE, it soft'fades out to just above silent, push again and it fades back up to the preset volume level

Now, before everyone starts asking, there are MANY other dispalys and function screens which come up while programming this option. I have NO idea what they do, and nobody has been able to give an accurate answer, including the dealer.

I can tell you, (and again thanks to MATT G yesterday), for his help with adjusting the HK auto volume/bass control. While in the program mode, depress the '+' key until the word GAL appears, it should have a 3 next to it (normal factory preset). By using the station presets, you can choose a sensitivity level from 1 thru 6 1-min 6-max sensitivity. When thru with this alone or both choices, turn the radio off again and it will be set. You will have to possibly reset your fade/treble/bass, etc.

Also while scanning thru the program options with the '+' key, you will see one display that shows your station presets on the display with a number to the right. It is the signal strenght of the station that is on at that time 1 weakest/15 strongest. You can survey all your own preset stations by pressing each preset key. (This info was also supplied by someone else yesterday, but I am posting it again to help some others today, I cannot take credit for this one, only for finding the MUTE control).

FYI: One thing I noticed is that after the MUTE function is programmed, the ST does not display any longer next to the station number, but it still broadcasts in stereo mode. Also, when turning the radio back on, the words "REG OFF" appear. I have no idea what this means, but it hasnt changed anything that I saw or used before and now I have the MUTE as well.


This is the thread: http://forum.e46fanatics.com/showthread.php?threadid=46707&highlight=mute+button
 
1 - 15 of 15 Posts
Top