BMW E46 Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
889 Posts
Discussion Starter #1
I have one side of my Angel Eyes out. Can anyone suggest the best methode to troubleshoot? They were installed in the car when I bought it so I'm kind of lost as where to begin. Thanks.
 

·
Registered
Joined
·
644 Posts
The first thing I would check is the ground going out from the inverter (ballast) of the not-working side. On mine it's a brown wire (not sure with yours). Make sure that it's securely connected to a grounded spot.

If that doesn't work, try to unhook the power inverter (ballast) from the working side, and plug the wires from the non-working rings into that inverter. If they light up, you figure you either have a bad ground or a busted inverter. If they don't light up, you might want to come back or call their customer support.
 

·
Registered
Joined
·
889 Posts
Discussion Starter #3
I believe that the problem is the ignightor ballast box. Problem is I have no idea who made these angel eyes since they were already installed when i bought the car. Any idea how I might be able to tell who made them so I can run down a replacement part? There are no markings on the ballast box itself.

Thanks.
 

·
Registered
Joined
·
644 Posts
I'm not too sure about how to tell who made them. Might want to post pictures of the rings and the inverter/ballasts. I remember seeing a link a while ago of an inverter that fits angel eyes perfectly, not sure though, might want to look around for that.
 
1 - 4 of 4 Posts
Top