BMW E46 Fanatics Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
:censor:

In the past 3 weeks the right front window regulator broke, i have a strong oil smell (most likely the crank case ventilation valve), the transmission slips sometimes for no apparent reason, and the power steering completely stopped working...

The power steering pump never made any loudnoises at ALL!!(like most failing PS pumps.) so i find it hard to believe that it died, but i cant imagine what else it would be.

anyone else had this happen? how much is a rebuilt pump?
 

·
Registered
Joined
·
593 Posts
where at in pa??

these cars arn't that bad. just keep a 500-1000 dollar "bmw fund" and you will be all set.
 

·
Banned
Joined
·
2,061 Posts
window regulators is a known. Be lucky if you don't have to replace those about every year or two..........
 

·
Banned
Joined
·
2,061 Posts
lucky.....

106k and I have replaced 4......

2 driver side. One front passenger, Other left rear passenger...
 

·
Registered
Joined
·
282 Posts
Just got mine 2 months ago and the ps pump went out too
It's your ps pump. I did get a groaning noise a couple weeks prior then went away. One day leaving the store....nothing! No ps at all. The shaft in the pump broke. go to http://www.autohauzaz.com. they have rebulit pumps if you want to do it yourself and save $$
 

Attachments

·
Registered
Joined
·
33 Posts
Discussion Starter #10
Here is an update on my car...


the PS pump went, it cost me $800 total, with the new pump, labor and the upgraded hoses.

i had to replace both valve cover gaskets, thats where the oil smell was coming from.

a months ago, the trasmission failed (steptronic, no reverse)...

i put a used tranmission in it about 2000 miles later, and now this one FAILED!!!


Im really getting pissed off.. since the econemy took a crap, im totally upside down in my loan, and i hate dumping more money in this car!!


im thinking i might swap in a 5 speed...
 

·
Registered
Joined
·
1,115 Posts
Here is an update on my car...


the PS pump went, it cost me $800 total, with the new pump, labor and the upgraded hoses.

i had to replace both valve cover gaskets, thats where the oil smell was coming from.

a months ago, the trasmission failed (steptronic, no reverse)...

i put a used tranmission in it about 2000 miles later, and now this one FAILED!!!


Im really getting pissed off.. since the econemy took a crap, im totally upside down in my loan, and i hate dumping more money in this car!!


im thinking i might swap in a 5 speed...
:confused:
 

·
Registered
Joined
·
994 Posts
sounds like all common problems of an e46 to me lol. u just happened to get an all in one package of the problems. do u only smell the oil leak on a slant hill? or on flat grounds? do you park on a driveway with a slant hill?
 

·
Registered
Joined
·
136 Posts
Dude, same **** with my car when I first got it. Drove it for about a month and wham everything went wrong, over 3 grand in repairs (Cracked Rear springs, bent rims, valve cover gasket, washer fluid leak, control arms, new axle due to cv boots leaking for some time, other stuff I cant remember...) Read up on here the stuff that usually goes wrong at about 100k and check that stuff out. As soon as I got that taken care of and made some friends that can help with repairs from time to time I got my car running really well, and still going strong at 112k. Where are you at in PA?
 

·
Registered
Joined
·
402 Posts
I think u got have 100,000kms (whatever that is in miles). Thats where most things start to crap out. I had crap like that happent to me.

Learn to accept it or just sell the car. I opted to just accept it
 

·
Registered
Joined
·
292 Posts
Just got mine 2 months ago and the ps pump went out too
It's your ps pump. I did get a groaning noise a couple weeks prior then went away. One day leaving the store....nothing! No ps at all. The shaft in the pump broke. go to http://www.autohauzaz.com. they have rebulit pumps if you want to do it yourself and save $$
Mine did the exact same thing a month after buying the car. It was fine until one time I started the car, and nothing. Impeller shaft was broken... Replaced it myself in about 2 hours for $250.

My recommendation:


Turner has it on sale right now. http://www.turnermotorsport.com/html/detail.asp?PRODUCT_ID=B301/B305
I have one for all my cars. Saves me a LOT of money.
 
1 - 20 of 24 Posts
Top