BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I have a SES light with EML light, the code is pointing at the TPS tested the one on the front of the motor and it checks fine.

I want to test the pedal but can't find out how to remove it, does any one have a link:bow:
 

·
Registered
Joined
·
678 Posts
There is a white tab at the bottom of the pedal take a flat blade screw driver and push down on it towards the floor and pull the pedal towards the drivers door it slides off a bracket
 

·
Registered
Joined
·
124 Posts
There is a white tab at the bottom of the pedal take a flat blade screw driver and push down on it towards the floor and pull the pedal towards the drivers door it slides off a bracket
Yep, Hold it up the entire time your sliding it or it gets hung up a second time. If you figure out how to test it, post it here. I was doing this last night and cant find the right combo of terminals to read.
 

·
Registered
Joined
·
77 Posts
Are you sure you checked it right? In my case, I had the same problem, checked the front (above oil filter) TPS, it was fine, so I replace the whole pedal/TPS and the problem was still there. So I ordered another TPS for the front, replace that one, and it's been good since then. But it's up2u. I would try to replace the front first, which cheaper than buying the pedal TPS, and easier.
 

·
Registered
Joined
·
458 Posts
I just did mine yesterday. I hope these pictures help. I needed 2 flat heads to do it. Using one push down the tab. With the other try to fit it between the clip. Once you do that try to get the bigger screwdriver in that position. Then pull lightly. If it doesn't come out easily. You don't have the clip pushed down enough.

Sent from my ADR6300 using Bimmer
 

Attachments

1 - 5 of 5 Posts
Top