E46 Fanatics Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 · (Edited)
Hello!

I have a weird problem after i replaced the alternator (The old one was noisy).

For example, after i turn the engine off, the ABS light comes and stays ON for 1 second. Same applies for other lights from the OBD, if i have ASC disabled and High Beem or handbrake lights on, they are still on after i shut down the engine for 1 second. This didnt happened before i replaced the alternator.

The values are 14.3-14.5V with car on, and 12.6V with car off.

E46 320d , 1999


Edit:::**

Here is the video wih the problem.

https://www.dropbox.com/s/cn3vwew7ihr64gi/VID_20170319_193639.mp4?dl=0
 

·
Registered
Joined
·
12,199 Posts
Hmmm, you did disconnect the battery when you replaced the alternator?

Try this BMW approved procedure:
- disconnect the ground/earth cable from the battery
- disconnect the positive cable from the battery
- short the cables together for 10 minutes
- reconnect the positive cable to the battery
- reconnect the ground/earth cable to the battery (sparks are ok)
- reset the clock

This forces all the electronix to perform a hard reboot.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hmmm, you did disconnect the battery when you replaced the alternator?

Try this BMW approved procedure:
- disconnect the ground/earth cable from the battery
- disconnect the positive cable from the battery
- short the cables together for 10 minutes
- reconnect the positive cable to the battery
- reconnect the ground/earth cable to the battery (sparks are ok)
- reset the clock

This forces all the electronix to perform a hard reboot.
Hi! Thanks for your reply :)

I tried this, but still no luck. The cables have been shorted for 20-25 mins.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top