E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
So my car finally threw rich codes. P1084 fuel control mixture bank 1; P1086 fuel control mixture bank 2 and pending code P1500 ICV stuck open.

Some of you may have seen my recent post

http://forum.e46fanatics.com/showthread.php?t=1040169

I think we were heading towards a MAF issue, which it could still be for the longer term rich condition I have, but is my ICV the issue for these codes? Too much air? Or is the ICV code just the result of a separate rich issue?

PS these are my first codes in over 2 years!
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #2 ·
This is the PM I have done so far:

cleaned the tb, ICV, disa upgrade, vanos upgrade, cooling system refresh, replaced fuel filter and pump, changed intake boot and ICV grommet, and replaced pre cat o2 sensors.
 

·
Premium Member
Joined
·
28,953 Posts
Here it the deal, the ICV is just like you putting your foot on the throttle. If the ICV was stuck open, then the engine RPM would be a bit too high, but the fuel mixture should not be out of line, again, the ICV opening is really no different than you putting your foot on the the throttle.

Not sure what cause the ICV suck open code to trigger, maybe engine idle a bit too high or does not drop back like it should when lifting your foot from the throttle.

The other codes basically mean the fuel mixture is more than 10% out of line from where it is expected to be.

P1084 & P1086 are RICH codes. Again, your fuel trims agree with this from the other thread, however, there are VERY FEW situations where the engine is really running Rich, most things degrade or get dirty in the fuel system or engine and the fuel mixture becomes LEAN.

Most RICH conditions I deal with are from sensor providing BAD DATA.

I would possible remove the ICV and clean it to make sure it is not stuck.

RICH mixtures would typically be caused by:

Fuel pressure being too high (rarely happens)
Fuel injectors stuck or leaking (rarely happens)
EVAP purge valve stuck open or not fully closed (can happen, but may also cause Lean codes as too much air may be available to the engine)
Engine temperature too low, not hard to
MAF over reporting the airflow, not a usual event, most likely caused by a wrong or counterfeit MAF
IAT reporting temperatures significantly off
Other unusual situations might cause a Rich mixture indications such as wrong or mis-wired O2 sensor(s), cam timing problems, exhaust restrictions, electrical system issues with charging Voltage or bad grounds, however, these are rather unusual situations and the other basic systems and checks should be performed before worrying about these as possible sources of the problem.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #4 ·
Well I drove the car this morning. Started her up no EML light. Went through my regular routine to get to work, lunch and home and no issues. It was like it never happened. On the way home, I plugged in my phone and ran torque. MAF, coolant temp and fuel trims were "normal". In other words slightly cool, running about 8% rich.

I checked for codes and the pending p1500 ICV stuck open was gone and the only ones left were the actual faults p1084 and p1086 which I promptly cleared.

Is it possible my ICV hiccuped and caused the above codes? Based on my understanding of how the ICV works, it would have been closed while driving and when it gets stuck open it would have caused a vacuum leak therefore a lean condition not a rich condition vs amount of fuel available. Thoughts?
 

·
Premium Member
Joined
·
28,953 Posts
Well I drove the car this morning. Started her up no EML light. Went through my regular routine to get to work, lunch and home and no issues. It was like it never happened. On the way home, I plugged in my phone and ran torque. MAF, coolant temp and fuel trims were "normal". In other words slightly cool, running about 8% rich.

I checked for codes and the pending p1500 ICV stuck open was gone and the only ones left were the actual faults p1084 and p1086 which I promptly cleared.

Is it possible my ICV hiccuped and caused the above codes? Based on my understanding of how the ICV works, it would have been closed while driving and when it gets stuck open it would have caused a vacuum leak therefore a lean condition not a rich condition vs amount of fuel available. Thoughts?
:facepalm:

Normal???

What is Normal?

-8% (Rich indication) on Fuel Trim is NOT normal. Normal Fuel Trim values are 0% to +2.5/+3.0%.

Engine running "cool" is NOT normal. 205F/96C is "normal".

Do you have the SES/CEL/MIL light coming on? And/or do you have the EML light coming on? 2 very different lights.

ICV should not cause Lean or Rich conditions, it should only impact the engine RPM as ALL air passing through the ICV "should" be properly accounted for and metered via the MAF. ICV being stuck open will not impact the fuel mixture on a car that does not have other vacuum leaks or problems.

Need Freeze Frame data and you need to report back the engine coolant temp at idle after about 10-15 minutes of driving and post Freeze Frame data next time the SES/CEL/MIL comes on.

Also Fuel Trim valves at warm idle and steady cruise 45-60 MPH would be useful.

You list a lot of PM items that were performed, were these recently performed? You might check the ICV connector or make sure the ICV was properly seated in the ICV grommet. A smoke test may also be something to consider. Make sure both the intake air path AND the crankcase is smoke tested.

Do not forget about the hose that connected to the fuel pressure regulator and the problems with power brake boosters that are starting to show up.
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #6 ·
I know it's not normal (see my other post I refer to in post #1). what I was trying to say was based on my codes I was expecting -20% LTFT not what I was running prior to throwing a rich code. I wasn't throwing a code at -9%.

Ltft was at -8.2% at 60 mph, same at idle; stft -2.2 to 1.6%, at idle it was at -1 to 3% IIRC. MAF was about 4.2 g/s at warm idle. Coolant temp at 60 mph was 92-84c, at idle it was 92c (same as before I threw the codes yesterday).

No EML light. last time I did any work on that side of the engine was when I did the ccv 8 months ago. Never threw a code for anything prior to yesterday.

I was reading about the brake booster too. I had a quick look over the weekend if I could hear anything or see any cracks as my daughter pumped the brakes. A complication is my brake booster and master cylinder are on my drivers side (RHD in Australia) so the hose goes across the engine via a metal pipe to the vacuum inlet on the engine block. Is there a way to test?
 

·
Premium Member
Joined
·
28,953 Posts
I know it's not normal (see my other post I refer to in post #1). what I was trying to say was based on my codes I was expecting -20% LTFT not what I was running prior to throwing a rich code. I wasn't throwing a code at -9%.

Ltft was at -8.2% at 60 mph, same at idle; stft -2.2 to 1.6%, at idle it was at -1 to 3% IIRC. MAF was about 4.2 g/s at warm idle. Coolant temp at 60 mph was 92-84c, at idle it was 92c (same as before I threw the codes yesterday).

No EML light. last time I did any work on that side of the engine was when I did the ccv 8 months ago. Never threw a code for anything prior to yesterday.

I was reading about the brake booster too. I had a quick look over the weekend if I could hear anything or see any cracks as my daughter pumped the brakes. A complication is my brake booster and master cylinder are on my drivers side (RHD in Australia) so the hose goes across the engine via a metal pipe to the vacuum inlet on the engine block. Is there a way to test?
Around 10% is where the fuel mixture codes get triggered.

If the Long Term Fuel Trim is out of whack at highway speeds, this usually is an indicator of a MAF issue. Coolant temp may be a bit low, but it is a bit tricky because of the heated thermostat and how the coolant temps drop under load and it is also dependent on your ambient temp, which I assume is on the cooler side these days?

The brake booster would no likely be a main source of your problem, but it worth at least ruling out as an issue. You can listen for leaks under the dash, pinch off or disconnect the hose or smoke test the booster and line. If the booster is bad enough to be a problem, you should hear vacuum hissing from under the dash I have not seen how much plumbing is for a right hand drive car, but it sounds like there are at least a few more connections.

But again, vacuum leaks should cause fuel trims to be in the positive (+) range.
 
1 - 7 of 7 Posts
Top