BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I recently got an 06 330i. This morning it started like normal, perfectly fine, then about 20 minutes ago when I went to start it again it cranked about 3 and times and sounded pretty slow then it just stopped. I tried again a few minutes later then once again cranked a few times then stopped. Can it possibly be the starter or battery? The electricity seems to be working fine though.
 

·
Registered
Joined
·
415 Posts
It could be the battery but lights, etc would be acting funny. Do you happen to know how old it is? If it's not that, it's likely the starter. Mine gave out at 130k on my 328i. Talked to a few local shop owners and they all said the e90's (at least the early ones) had some pretty weak starters
 

·
Registered
Joined
·
396 Posts
Mine after parking from a run to town I went back out to crank and all it did was turn over, no crank. It ended up being the DME, EWS,CAS. They were not communicating properly. Old battery must have dipped to low causing the old gal to lose her mind (lol). All the tech had to do was hook up his huge Autel diagnostic and realign the DME with the EWS or CAS I cant remember but then she started right up. New Battery of course it was 10 years old..And mine is an 06 as well.
 

·
Registered
Joined
·
396 Posts
Mine after parking from a run to town I went back out to crank and all it did was turn over, no crank. It ended up being the DME< EWS<CAS. They were not communicating properly. Old battery must have dipped to low causing the old gal to lose her mind (lol). All the tech had to do was hook up his huge Autel diagnostic and realign the DME with the EWS or CAS I cant remember but then she started right up. New Battery of course it was 10 years old..And mine is an 06 as well.
 

·
Registered
Joined
·
396 Posts
2006 330i crank no start

Mine after parking from a run to town I went back out to crank and all it did was turn over, no crank. It ended up being the DME< EWS<CAS. They were not communicating properly. Old battery must have dipped to low causing the old gal to lose her mind (lol). All the tech had to do was hook up his huge Autel diagnostic and realign the DME with the EWS or CAS I cant remember but then she started right up. New Battery of course it was 10 years old..And mine is an 06 as well.
 
1 - 5 of 5 Posts
Top