BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi People I'm very new to this forum stuff plus im a bit of a technophobe so please hang in there with me?
I am the proud owner a 2004 320d with an MTEC Kit but I now have a small problem which could turn nasty! After covering about 150 miles or so on a journey there was a loss of power. Depressing the throttle had no effect for about 30 secs, then I had full power back. This problem persisted in the same manner for the rest of the journey (50 miles or so).
The next day the car started and ran perfectly untill i had driven 140 miles and then the same problem started once again.
The car idles fine, If switched off during this intermittent problem, it starts as normal but 2mins later it's back.
I can't hear any other signs of a component problem.
The car has been well serviced over the years and has 132,000 miles on the clock.
I have read other threads about replacing Air Filters, what do ye reckon?
Any help would be much appreciated.

Cheers

Glenn
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Oh no

Thanks for the responce, just talked to a mechanic friend, said I should get rid of car quick if it's the fuel pump as they are circa €3000 to replace :(
 

·
Registered
Joined
·
61 Posts
Hi

If its fuel pump, try euro car parts website. £200 should sort it.
Try obvious things like fuel filter, airflow meter, air filter, any cracks in hoses, any leaks before you spend big money

Does your car have any mods? Try a diagnostic with your local indy?
 
1 - 5 of 5 Posts
Top