E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
3 series coupe 318ci 02 not starting
My 318ci 02 year just suddenly stopped starting after air filter was changed. Car never had a problem before this. I've checked fuel pump and relay are both working fine! I don't know what else to do?
Has anybody got any suggestions?
*
 

·
Registered
Joined
·
1,889 Posts
Reading 318ci and your thread title, I could be forgiven for thinking you're from another country and English isn't your first language! :D


What are the syptoms? Does it crank at all? To start a car you need spark/compression/fuel.
 

·
Registered
Joined
·
98,872 Posts
Symptoms? Does it crank?

Start with the obvious first. Is the battery connected properly? Is it charged? Did you disconnect the MAF wire at all and forget to plug it back in?
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 · (Edited)
Yes I'm from england it's jus my iphone messin about so the words came out wrong lol anyhow yes I've checked battery, the
Maf cable is plugged in, the car does crank but it's like there's no spark or no petrol getting to plugs but the pump 100% works. I've had it put on one of those meters that check for faults and 2 faults have come up that wernt there a week ago when I had it checked. 1 says sumthin about exaust sensor?? Another says sumthin about engine sensor ( something like that anyway from wot I can remember off top of my head)
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Can a e46 that has never had any mechanical problems in the past just stop working Out of nowhere just 5mins after it has jus been running all day?? I had only stopped at a garage to have my air filter put on correctly as it hadn't been put on tight enough the day before when I had it changed
 

·
Registered
2016 340i xD 6-spd
Joined
·
26,996 Posts
I'm personally a big believer in proximate causes, but to answer your questions...10 mins. here in fanatics should tell you...yes, our cars break, and often without warning.

I personally also think that often the warning signs are there, but owners don't notice for whatever reason (one theory I have is the 10,000 W subwoofer drowning out the sounds of warning...but that's another thread!).

Anyway, Kalim beat me to it (this time...but there will be others! :lmao:).

The maf is really delicate...but another thing I'm wondering about with the maf is this: cars with messed up mafs run better when maf is disconnected--that's one of the methods of identifying it as an issue). So, if your maf is connected, it may have failed in an unusual way such that the car won't start...(maybe disconnecting maf only improves things when it's failed, and the car is already started...not sure about that.) But try disconnecting it.

Also, do you have aftermarket air filter? An oiled kind? If so, I've also heard that sensors can get messed up, so if you'd just changed the filter...had oiled it too much, maybe oil residues had messed up a sensor...and so it would still be proximate cause, just deeper inside engine. The camshaft position sensor, I know, if failed, can lead to a no-start.

A mechanic can test it (and I know you got codes...important to remember them...does cam shaft position sensor sound familiar?). Not too difficult to remove that one sensor anyway...just behind the vanos intake solenoid...unscrew top of it, remove sensor, maybe try cleaning it (with what, I'm not sure...'maybe' parts cleaner).

Also, search 'no start'--could be bat as mentioned, could be key (try another), could be many other things, but work up from simple to expensive!

HTH

Doug
 

·
Registered
Joined
·
98,872 Posts
Well, seems that Doug is heading where I was - the sensor codes. A faulty crankshaft sensor can prevent the engine from starting and the camshaft sensors will affect fuel management.

So remember those codes! Might be flukes from something else messing the air/fuel mix up so check over everything you touched first.

Good luck!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #8 ·
Cheers thanks guys, I'm just waiting on my mechanic to send me the fault codes then I will post em on em here, in the mean time I'm going to try another key, also try turning it over without the maf plugged in and c how I get on. Don't think my air filter is the oiled kind as I don't recall seeing the mechanic oil it before putting it in... Camshaft position sensor Does ring bells..
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #10 ·
Mechanic hasn't given price yet As he don't kno what the problem is yet as to why if won't start, but once I find out I will let you know!
 

·
Registered
Joined
·
98,872 Posts
Keep us posted!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #12 ·
Right the mechanic has now checked pretty much everything that has been suggested in this post and he has now checked the plugs too, he said he done a compression test on the cylinders ( think its the cylinders, or somewhere abouts where the plugs go). He said the compression is low in cylinder 1 and the rest were ok. So now he is saying he will need to send it off to Bmw specialist?? Which is what I was tryin to avoid as it will probably be big monies. What else can I do before sending off to BMW??
 
1 - 12 of 12 Posts
Top