E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 · (Edited)
I have a 2006 M3 Convertible with 51k miles. Inspection 2 was done, my vanos bolts are upgraded and when i just got the car it blew the smg relay which was replaced. It has developed a noticable vibration felt in the gas pedal in 1st gear between 1-2k rpm, usually around 1500. I have to drive 11-13 miles in order for this problem to develop, it will not happen right away and it will only happen in 1st gear. If I turn my angry button all the way down and the car starts in 2nd gear, there is no problem. Also if i drive it in manual and start from 2nd gear, there is also no problem. Finally, when I am braking right before the car is about to come to a stop it seems to skip a beat as if the brakes release and regrip once. It only does it once on the dot and only right before the car comes to a complete stop. if i apply more pressure the car brakes abruptly when the brakes re grip, if i keep the pressure the same the brakes re grip momentarily. I thought it was an air bubble in the brake lines but once i started driving the car in 2nd gear the problem did not occur. So there seems to be an issue with my first gear. Has anyone ran into this before?

The car is currently at the dealership being road tested as they have to get it up to 13 miles for the problem to manifest.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #2 ·
So just an update. I seem to have resolved the problem by doing the SMG Reset (going 40mph shifting to neutral and holding down both paddels) and cleaning my MAF sensor in that order. So far the Clutch Shudder has not shown up. I will keep updating this thread in case anyone else has the problem.


 

·
Registered
Joined
·
1,088 Posts
yeh, i have the same problem with my 02 vert SMG, i read somewhere that its normal to feel this?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #7 ·
Glad to hear you got it resolved. Keep us updates on the problem. Have you inspected the transmission fluid?
Im not 100% sure its resolved, it has come back 1nce or twice but nowhere as bad as it was. The issue on the braking is completely gone and the vibration is almost gone. What am I looking for as far as the transmission fluid goes?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #8 ·
yeh, i have the same problem with my 02 vert SMG, i read somewhere that its normal to feel this?
It's apparently a very common problem with SMGs and there is plenty of threads regarding this. Its called an SMG Shudder and when i took it to the dealership they could not recover any codes or find anything wrong. Long story short there are a number of fixes to this problem but no consensus on one working one. It ranges from resetting the smg system to cleaning the maf filter to changing the coil pack, fuel pump and finally clutch and flywheel. Also you could try reprogramming the smg system or installing csl software but thats way above my knowledge base and I have not found a good indie shop in the brooklyn area which specializes in this yet. If anyone knows one it would be very much appreciated.
 

·
Registered
Joined
·
27 Posts
I bet the stopping issue you described....

....is the SMG shifting from gear into neutral automatically as you slow to a stop, so now the car is rolling faster as there is no transmission slowing the car down, and then you hit your brakes harder and it stops the car.

So it FEELS like your brakes stopped working so well and then worked again, but really you just came out of gear so you were coasting instead of having the transmission continue to help slow you down.

Make sense?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
Yes it does. The issue was the flywheel. I just had a clutch and flywheel job done approx 1 month ago and all of these problems went away. Car feels and shifts like brand new. Its 100% worth it. I had mine done @ Bimmerclinic. Awesome job!
 

·
Registered
Joined
·
27 Posts
Yes it does. The issue was the flywheel. I just had a clutch and flywheel job done approx 1 month ago and all of these problems went away. Car feels and shifts like brand new. Its 100% worth it. I had mine done @ Bimmerclinic. Awesome job!
Ouch! Sounds pricey, what did it run you?

Seems way to early for those items at only 50k miles. :hmm:
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
It ran around $2200 with everything. The Clutch did not need to be replaced but since everything was apart, might aswell do it so everything is fresh. And yes it is too early for those items at only 50k miles however I have been researching this on the message boards and the flywheel gets glazed over and begins shuddering in first gear. Its not a necessary repair, if you can live with a slight shudder, you can drive all the way to 100K but I couldn't stand it and now the car runs like new and its worth it 100%.
 
1 - 12 of 12 Posts
Top