E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi
I just got a 330 zhp and only one speaker works. the only that works is the passenger side rear on the deck. the previous owner said that the other rear one will work on and off. I don't think they a blown because there is no static sound coming from the other speakers.
 

·
Premium Member
2005, E46 Convertible, 330CI M Sport Auto, Mystic Blue, 76k Miles
Joined
·
427 Posts
I'd take the panels off and have a look at them
 

·
Registered
2005 BMW 330i
Joined
·
941 Posts
the car has HK and nav
I had this same issue. I swapped out amps with no luck and ultimiately ended up buying a new android headunit, that looks very similar to the OEM Nav. But includes bluetooth and apple carplay and android auto. Best $250 I spent.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
Help, please! Im still having this problem. i recently unplugged the battery and now I have no sound coming from the speakers.
 

·
Registered
Joined
·
11,642 Posts
Perform an electrical system reset:
  • disconnect the negative cable from the battery
  • disconnect the positive cable from the battery
  • short the cables together for at least 10 minutes
  • reconnect the positive cable to the battery
  • reconnect the negative cable to the battery (sparks are ok)
  • reset the clock.
 

·
Registered
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
7,468 Posts
Perform an electrical system reset:
  • disconnect the negative cable from the battery
  • disconnect the positive cable from the battery
  • short the cables together for at least 10 minutes
  • reconnect the positive cable to the battery
  • reconnect the negative cable to the battery (sparks are ok)
  • reset the clock.
↑ THIS ↑

In BMW repair speak, this is called a "Battery Reset."
 
1 - 9 of 9 Posts
Top