E46 Fanatics Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi

So after i bought the car i realized the electric cooling fan is bypassed, and my aircon not working, however after I diagnosed my aircon i figured the aircon wont kick in as the the cooling fan was directly connected to ignition so it comes on when ignition is switch on... Long story short took the cooling fan out to realize the controle module is not there so bought a cooling fan with control module hooked it up like it should be also not turning on when car becomes hot, bought a second one... The same... Also not turning on... I read alot of this discussions where people talk about the lower radiator hose coolant tempreture sensor... However my car doesnt have one and also confirmed on realoem, doesnt have that sensor, also checked the wires and is getting 12v to the module and fuse is not blown, any ideas what can cause this? Thermostat? I did confirm with the previous owner and he stated the fan did work but when it stopped working the auto electrician bypassed it to prevent overheating... Since i had the car (for a year now) she never overheated as im driving currently without a working fan... Any suggestions? Ive search all forums and nothing except people that points to coolant tempreture senser on lower rad hose (which my model doesnt have) also drove car to about 95'C-100'c and still doesnt kick in... My aircon's gas i emptied havnt refilled it as yet...

Advise would be greatly appreciated as ive spend a lot of money now and still doesnt work
 

·
Administrator
Joined
·
17,736 Posts
Sounds like your car wiring is a hacked up disaster. Best to restore it to stock so everything works properly.
Find the wiring diagrams on newtis.info.
Set up BMW Standard Tools so you can use INPA to view live data. Hit the link in my sig.
 

·
Registered
Joined
·
62 Posts
My electric fan would not work when my ac was not charged. Started working right after I was able to get it recharged.
 

·
Registered
2003 330i
Joined
·
191 Posts
That ain't right. The engine fan must cool the engine, regardless of the state of the air con charge.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
Something has to tell the engine computer (DDE as it’s a diesel) the temperature of the coolant.
Hi,

Tested another two fans today still nothing... The on board and diagnostic tool shows it reaches 100'c celsius and still not kicking in... So coolant sensor is working
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
Something has to tell the engine computer (DDE as it’s a diesel) the temperature of the coolant.
However accroding to other discussions there is a primary and secondary coolant sensor... I have no secondary sensor, check on radiator and the lower radiator hose, nothing...
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
This is the error codes according to diagnostics...

BMW_EN_TEST_00002>All Series Except X3>Smart Scan>ECM-DME-DDE(Digital Motor-Diesel Electronics)>Read Fault Code:
Total Number : 15
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4100 1/15
State: Current
A/C-capacity output
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
41F1 2/15
State: Current
Electric fan
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
41F2 3/15
State: Current
Electric fan
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
41C2 4/15
State: Current
Radiator blind
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4203 5/15
State: Current
Glow control module
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4521 6/15
State: Current
Charge-air pressure control
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4B90 7/15
State: Current
Rail-pressure monitoring on engine start
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4560 8/15
State: Current
Rail-pressure plausibility delivery-controlled
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4570 9/15
State: Current
Rail-pressure plausibility delivery-controlled
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
3FB1 10/15
State: Current
Air-mass flow sensor
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
41A2 11/15
State: Current
Charge-air pressure controller
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4212 12/15
State: Current
Glow plug, cylinder 1
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4222 13/15
State: Current
Glow plug, cylinder 2
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4232 14/15
State: Current
Glow plug, cylinder 3
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
4242 15/15
State: Current
Glow plug, cylinder 4

I have to say... I have no starting problems even i cold mornings....
Is it possible that i might be unlucky to have a malfunctioning dde?
 
1 - 13 of 13 Posts
Top