E46 Fanatics Forum banner
1 - 3 of 3 Posts

· Registered
2002 330ci
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a new to me 02 330ci was idling fine but was over heating. I replaced all of the coolant hoses, ET, and was able to get it not to overheat. I also have to replace the exhaust gaskets because they rusted off completely. I was running it like that as I was working on it and without the MAF connected. Now the EML light came on and it sounds like it's idling really rough in limp mode. Do you think running it without the MAF put it in limp mode?
 

· Premium Member
2000 E46 323i, 3.0L, 2.8L and 2.0L Z3's
Joined
·
2,583 Posts
Your rough running is likely something to do with the work you have done and is possibly a vacuum leak.

Running the engine with the MAF disconnected is OK. It gives the engine a rich mixture, which tends to mask the smaller vacuum leaks.

Check the exhaust gaskets and make sure that you don't have a leak. A leak before the pre-cat O2 sensors gives lean (vacuum leak) like problems.

Plug the MAF back in.

Check for other vacuum leaks and smoke test the engine if possible. Read: How to Smoke Test

Also read: DIY: Fuel trims, lean codes, misfires and how to...
 

· Registered
2002 330ci
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the quick reply, both of my donut gaskets are rusted completely off, I haven't had a chance to have them replaced yet. I'm sure that is the culprit if my lean condition but do you think it would cause my limp condition? Thanks
 
1 - 3 of 3 Posts
Top