BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hey everyone I have been searching the threads forever and cannot find anything. I have a 323ci with 180 thousand miles on it. Sometimes the car will not engage into reverse, most of the time it will but sometimes not (say 15% of the time). Im also am having troubles with the car having a very rough shift into second gar and slightly rough into 3rd. The shifting gets better with driving through the day but at first it feels like someone dropped the clutch in a Manuel car. Surprisingly enough the car is not in limp mode but is throwing a p0700 (transmission control system malfunction) and a p0732 (gear 2 incorrect ratio). I took the car to AMCO and their first response was to pull the transmission and replace it (I can do this myself), I told them no and they told me to replace the trasmission. From the conversation I had with the guy at the transmission shop they didn't do much to determine the problem it seemed like they more just wanted my money. So what i'm looking for here is has anybody else had a similar problem to this ? Also could it be a TCS problem? I thought about replacing the TCS as a cheap option before going for the whole tranny. Thanks:)
 

·
Registered
2000 E46 323i, 3.0L and 2.0L Z3's
Joined
·
670 Posts
First off determine the make of auto transmission you have. Its either a GM or ZF. I'm picking its a GM transmission.

Do a google search on "bmw e46 reverse solenoid" and read up on how to fix the problem.

With your 2nd gear problem, it might be another solenoid issue, so read up on that too.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
First off determine the make of auto transmission you have. Its either a GM or ZF. I'm picking its a GM transmission.

Do a google search on "bmw e46 reverse solenoid" and read up on how to fix the problem.

With your 2nd gear problem, it might be another solenoid issue, so read up on that too.
I have the GM transmission and we already tried replacing the reverse solenoid, sorry I forgot to mention that in my original post.
 

·
the people’s mod
2004 330Ci 115k miles
Joined
·
14,346 Posts

·
Registered
Joined
·
11,072 Posts
When we’re the transmission fluid and filter last changed? You might consider a transmission fluid flush. Also, the transmission computer (EGS in BMWspeak) May be in need of an update.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
quick update

little update on this tranny is reverse eventually worked in the car after driving i around for a while ( it sat for 2 years before i got the car), then just last week the transmission blew out about 2 quarts of fluid and couple days later it blew out another 3 quarts after i refilled it. Tranny fluid was extremely burnt so i went ahead and swapped the old tranny with the new one from a salvage yard and now my new tranny dosen't go into 5th gear.

So going off of that instead of starting a whole new post ill just continue with this thread.

With the replacement tranny we got it in and it shifts fine from first to fourth but when fifth gear is needed it is not there. i've tried using the steptronic and it will not go into 5th just (in auto or steptronic). whenever i drive it not in steptronic it puts the car into limp mode and throws as p0735 gear incorrect ratio code. we also used my friends snap-on scanner to see and clear the tranny code and it was the same code. we cleared it and still popped on . soooo what the hell is wrong with this transmission now ? pretty pissed considering it was "tested and runs perfect" :ben:
 

·
OEM ///PLUS
2003 M3 6MT Slicktop
Joined
·
23,806 Posts
1 - 8 of 8 Posts
Top