BMW E46 Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So, I'm driving an 03 330xi and it's giving me a bit of trouble.
Before I get into it, I'll sadly admit that this one is an automatic with tiptronic :(

First, it has a whistling noise when i'm putting a low to moderate amount of throttle on it. I don't know if this is just a characteristic of automatic cars... somebody told me it was the intake. But I also heard something about a possible tear in an elbow (they didn't specify).

Second, when i'm doing a slow U turn on my hill with the wheel in a full turn, there seems to be a low "pop" noise that comes from the back about halfway through.

Third, I noticed when I turn it off that first, there is a rush of air supposedly from the intake and a flap on it but then a moment later there is a short gear-like grind that comes from the back.

My final issue is the one that worries me. Twice now, when at a complete stop and I slowly start to accelerate, the car won't respond. Instead it makes tiny jumps forward over and over again until the engine dies. First time, i got out, made a phone call and it was fine after. The second time, I started it up again much sooner and it had the abs, brake, and dsc (caution triangle w/ circle) lights on. Got back, let it sit, and no lights later when I restarted it. I was thinking fuel pump or filter at first. Others have mentioned transmission not catching or a few other things. Any ideas or experience with this?

I know this is a lot of questions, but some of them could be nothing from what I have been told so far.

Any help or experience with these is appreciated!
Thanks guys.
 

·
Registered
Joined
·
56 Posts
CEL? It should have triggered one by now. If it has go get the codes read and that will tall you a lot about what is wrong. From what you describe, it sounds like you have a leak at some point in your intake as well as something bad on your rear suspension. I would suggest looking on your intake and intake boot for cracks and places that could leak. As for the pop in the rear, I don't know enough about that to suggest anything, but i'm sure one of the other fanatics will have some advice.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3 (Edited)
Thanks for the advice, I'll look into that.
And I'll be getting the codes on it tomorrow or the next day to see what's going on. I just figured I'd see what our forum had to say so far while I wait.

Also, no lights are on when I drive it. Only that one instance with the abs, brake and dsc but those went away as well.
 

·
Registered
Joined
·
26,436 Posts
So, I'm driving an 03 330xi and it's giving me a bit of trouble.
Before I get into it, I'll sadly admit that this one is an automatic with tiptronic :(

First, it has a whistling noise when i'm putting a low to moderate amount of throttle on it. I don't know if this is just a characteristic of automatic cars... somebody told me it was the intake. But I also heard something about a possible tear in an elbow (they didn't specify).

Second, when i'm doing a slow U turn on my hill with the wheel in a full turn, there seems to be a low "pop" noise that comes from the back about halfway through.

Third, I noticed when I turn it off that first, there is a rush of air supposedly from the intake and a flap on it but then a moment later there is a short gear-like grind that comes from the back.

My final issue is the one that worries me. Twice now, when at a complete stop and I slowly start to accelerate, the car won't respond. Instead it makes tiny jumps forward over and over again until the engine dies. First time, i got out, made a phone call and it was fine after. The second time, I started it up again much sooner and it had the abs, brake, and dsc (caution triangle w/ circle) lights on. Got back, let it sit, and no lights later when I restarted it. I was thinking fuel pump or filter at first. Others have mentioned transmission not catching or a few other things. Any ideas or experience with this?

I know this is a lot of questions, but some of them could be nothing from what I have been told so far.

Any help or experience with these is appreciated!
Thanks guys.
+1 on intake leak...the 'elbow' on the lower intake boot rips. It's not the only intake thing that rips, but it's the best whistler we have.

Pop from the back on U-turn? Look underneath in the rear end for odd things. I'm thinking maybe a rear sway bar endlink...see if the rubber boots on both ends of them are intact...if not, they're suspect.

The Xi axles seem to have issues, but I thought mostly in the front...don't panic yet!

Look with good flashlight, like my favorite, the xl50.

Whooshing air/flaps on shut down...chewbacca noise maybe? That could be ccv. If you mean back of engine. If not, see if maybe you have a exhaust flap stuck...if you meant at the rear of the car.

There are other whooshing sounds I recall reading about but nothing is coming to mind.

Get someone to shut off car while you listen with a hose in your ear and isolate that sound. CCV is below 2-3 cylinder below intake manifold. That might just want a long hard drive to clean up, but maybe it wants a new CCV.

Final thing sounds like trans. Read up on that some more. It may be you need a trans fluid change/filter change. There may be a programming fix. I don't really follow auto problems too much...it just makes me all the sadder for you guys! :lmao:
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Just an update, along with no CEL being on, my car isn't throwing up any codes... Which i guess is good on it's own, but frustrating.
Makes me think my problem getting going might be a fuel pump issue? From what I've heard, that might not give any codes.
 

·
Registered
Joined
·
138 Posts
For the popping in the back have someone take a look at the rear diff. My buddies E30 had that same noise at full lock and it ended being something with his diffm(sorry I can't remember what it was :/). Whistle is most likely goi g to be the intake boot rip. But I'd think you'd have a CEL by now
 
1 - 6 of 6 Posts
Top