BMW E46 Fanatics Forum banner

21 - 29 of 29 Posts

·
Registered
'89 e30 m50b32tu
Joined
·
105 Posts
If you pressuring your crankcase (because you're boosted) you will blow out gaskets. You need 0 positive pressure in there. Ideally you want to pull a vacuum on it by routing to the turbo inlet.

If you put a check valve in the line going back to the intake manifold you will 100% pressurise the crank case under boost.
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #22
If you pressuring your crankcase (because you're boosted) you will blow out gaskets. You need 0 positive pressure in there. Ideally you want to pull a vacuum on it by routing to the turbo inlet.

If you put a check valve in the line going back to the intake manifold you will 100% pressurise the crank case under boost.
Hmm I can see how not having enough room for the pressure to vent/vacuum out could cause wear on gaskets, so in theory my setup is routed correctly because my check valve is one way allowing to the intake manifold not back to the crankcase, but I need more flow? I have some 1" leftover, I will go ahead and run full 1inch to and from the catch can and take your advice lol much appreciated
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #23
If you pressuring your crankcase (because you're boosted) you will blow out gaskets. You need 0 positive pressure in there. Ideally you want to pull a vacuum on it by routing to the turbo inlet.

If you put a check valve in the line going back to the intake manifold you will 100% pressurise the crank case under boost.
It didnt show me the second part of this until I reposted... if it goes to the intake which is from the turbo pressure, why would it not release from the crank?
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #24
Alrighty, got the oil pan off and cleaned up. Checked my oil pump nut since I read a few people ran into issues with theirs being finger tight. Mine was tight as hell, so I threw a little high temp thread sealer on the outside threads and slapped a new gasket and rtv on the oil pan. What do you know, no more drips overnight from.... everywhere. Redid my oil catch can setup, actually went from 1 inch to 1/2 inch the whole way, and instead of using the back vacuum port that didnt seal well, I did the return at the top of the intake manifold(little plastic rail the ccv originally hooked up too). I have a 1/2" check valve arriving today for it as well. Started her up for the first time and she ran superrrrr rich. light throttle to keep her going, smoked out my damn house. Dropped the FPR from 58 to 30. Still rich as hell. Decided to throw the stock injectors back in with the orings from the new ones, and what do you know.... idled like a champ. Did a quick test drive to work and back (3 miles away) and it didnt go knock knock knock so thats a win in my book. Holy god is it loud atm lol back fires and pops all day, does not sound like it should be coming from a 4 door sedan. Still have a million little things to put back together, adjust, tune etc but she is alive!
908172
908173
908174
908175
I don't go over like 2k rpm just making sure she makes it around the block
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #26
Had some time today to mostly finish up the front bumper and put all the plastics back together, obviously had to leave out the bottom mesh :) Gotta find where the tow hook insert thing went lol and decide on new fog lights. Threw in the 7 psi spring over the 4 psi for the time being with plans on 10 psi once I get it tuned
908278
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #27
Well she started to misfire and I have had one hell of a time figuring it out... plugs were a little fouled from the bigger injectors, threw a set of new stock ones in. Fixed it for a mile. Misfire on 3, 5, and 6. Swapped 1 and 3, 2 and 5, 4 and 6 coils. Runs for a mile, same thing misfire on 3, 5, 6. Pulled the oil cap and the Vacuum was ridiculous. Is it actually supposed to be crazy strong? Pulled the out line off the catch can, stopped the Vacuum and it ran and idled perfect. Hit boost 2 times. Parked it happy, came out 15 minutes later and misfire on 3 and 6..... what in the actual fuck...? Any thoughts?
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #28
Well I ended up running with 1/2 hose form the valve cover to catch can in. 3/8 from catch can to intake manifold. Upped the FPR to 70psi?(dont know how reliable this amazon cheapo is) and so far its running better and hasnt misfired. Trying to get an exhaust setup together, will post some videos once its on
 

·
Registered
2003 bmw 325i
Joined
·
22 Posts
Discussion Starter #29
Well I have had an "exhaust" on the car for a few days but have been busy as usual. Honestly not trilled with the sound. Went one resonator to a Thrush 2 chamber welded muffler. Sounds like the $45 I spent on it. Once I save up some cash I plan on buying a real muffler and having a shop redo all the piping. I will try to take a quick video in a little bit and upload. Now though for a few questions/spitballing. So my Traction lights have been on since before the swap because my mother moved my car and left the sunroof open. Then it poured because Florida. DSC switch went out. Still have to swap it but I'm not too stressed about those lights. Washer Res light is also a given atm, I will eventually figure out how to make that disappear. My confusion lies with my Service Engine Soon light. I have reset all inspections, oil, etc, yet it will not go away. If I plug in my peake reader, I can clear all codes, and it runs great with no light until I turn off the car and restart it. Then the light is back? Any thoughts? Other thing Is between 1500-2000 rpm when maintaining throttle input it seems to misfire/studder but not throw any codes? My assumption is a mixture of stock MAF and no tuning atm? Good old driver door locking mechanism took a shit right when I locked it. Can free spin the key in the door and nothing.... Of course the key hasnt worked in forever. So I cut it open, gave the damn thing power, and unlocked the car lol resynced the spare and so far it unlocks but doesnt lock... so needless to say Im leaving it empty and unlocked for the time being lol
 
21 - 29 of 29 Posts
Top