E46 Fanatics Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter · #1 ·
Help. When engine is at 5-6K rpm's (like when passing someone) the engine stutters and decides not to go over 4000 rpm's even when the pedal is floored!! If I shut the car off and turn it back on, it runs fine until I am at hi rpm's again. When the engine cuts off it hits me like a ton of bricks, like I just hit a wall. Also, when I start the car in the morning, the engine revs down to about 300rpms 6-7 times before leveling out. I am assuming that these two problems are related. I have had a clogged catalytic converter before in an older 325 and that is what the "cut off" sensation feels like. Anyone ever witness this before?? I was kind of hopping it was the engine recall so I can start over with 0 miles!

Thought you may get a kick out of this.. my fantastic BMW dealer just called me and said the all mighty diagnostic computer has the answer... low fuel!! (car was doing this with a full tank so that is rediculous) And he has even better news, they corrected my tire pressure. YEAH! all problems solved. Is there no such thing as a mechanic anymore or are they all "technicians"
 

·
Registered
Joined
·
383 Posts
i had this problem for the

longest time and couldn't figure it out. I took it to the dealer numerous times and he gave me some bull crap about my fuel tank being a saddlebag configuration and the engine not getting enough fuel but that was definitely not the case. I think it has to do with the exhaust system because when i went to an aftermarket dixis titanium exhaust the problem disappeared and i have had my exhaust for about 3 months now without any problem hitting the high revs and having the engine electronically limit me. hope this helps. :)
 

·
Registered
Joined
·
703 Posts
take it to the dealership.. the engine is under warranty at least..... i wouldn't keep driving it like that. all M3's have a slight rough idle when started but it goes away quickly.
 

·
Registered
Joined
·
453 Posts
rbelf your car is a 2001 how many miles you have on it. I have read on this site when the cars are new the dealer have the option of limiting the engine to 5k-5k RPMs to make the owner follow the break in period. I also read that most dealer don't do this because it raises too many questions from the owner.

tsang151 this could explain why your engine was doing that after it was replaced since you had to break it in again.

regarless what the problem is the dealer must fix it and give you an answer. Keep taking it back to the dealer.
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #7 ·
I bought the car in Nov '03 and havn't had any problems until the past week so I am sure that it is not the dealer installed governer. I know the //m is a little rough at idle but this is different...it almost stalls. I have about 31K miles. The problem actually started when I noticed my "service" light come on for about to minutes (service isn't due for 8K miles) I have heard that the light will come on when the engine is misfiring. I beleive it is an exhaust issue but it has to be some sensor that limits the revs in lieu of the actual exhaust. Newer cars also have a "limp home" relay which will limit the revs. I had this problem with my '00 323ci. I will let you know.


speaking of the exhaust, mine sometime sounds like a tin can. Is this the "rasp" that everyone talks about (that was the dealers answer anyway). If it is, it sucks because it is not consistant.
 

·
Banned
Joined
·
475 Posts
rbelf said:
I bought the car in Nov '03 and havn't had any problems until the past week so I am sure that it is not the dealer installed governer. I know the //m is a little rough at idle but this is different...it almost stalls. I have about 31K miles. The problem actually started when I noticed my "service" light come on for about to minutes (service isn't due for 8K miles) I have heard that the light will come on when the engine is misfiring. I beleive it is an exhaust issue but it has to be some sensor that limits the revs in lieu of the actual exhaust. Newer cars also have a "limp home" relay which will limit the revs. I had this problem with my '00 323ci. I will let you know.


speaking of the exhaust, mine sometime sounds like a tin can. Is this the "rasp" that everyone talks about (that was the dealers answer anyway). If it is, it sucks because it is not consistant.

i REALLY doubt the problem is related to yoru exhaust. Yes the tin can sound is the rasp...

as far as the rpm limiting and rough idle... i would venture to say its a computer problem. either coil packs or computer. Go get it looked at.
 

·
Registered
Joined
·
161 Posts
rearviewmirror said:
take it to the dealership.. the engine is under warranty at least..... i wouldn't keep driving it like that. all M3's have a slight rough idle when started but it goes away quickly.
lol rough idle when started is an understatement.. sometimes if i put the top down right after starting it in the morning it almost stalls
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #11 ·
i'll take 30 sec of rough idle in the morning for the pleasure of driving the //M all day! but the pleasure goes away when the F#$%ing car doesn't go over 4000 rpm!
 

·
frequent tire purchaser
Joined
·
633 Posts
I get a hesitation sometimes. Usually when I'm cruising at freeway speeds... I'll let off the gas for a second and then get back on it and it will stutter. It doesn't happen often. One time I was passing on a 2 lane road... at like 45 mph I jumped on the throttle and it cut out like 3-4 times, I shifted to fourth and it did it another 2-3 times... that was the worst so far though and it hasn't happened like that since.
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #14 ·
The "stealer" said they reprogrammed my computer. will let you know tomorow if it works. either way, I am shopping for a new exhaust...any suggestions?
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #16 ·
zera006 said:
I had same problem on my car. Dealer replaced mass air sensor and car is running fine now.....

The problem ended up being the fuel filter.
 

·
Registered
Joined
·
253 Posts
Is the EML light on?
 

·
Read Only
Joined
·
12,638 Posts
did you take the car in for the 30,000 mile check up....

i just had my 30,000 mile check up and found out that the dealer adjusts the cams i think but the mech. told me that the engine will run smoother after the 30,000 mile check up... look into serving your car it may to the trick maybe.
bobm3 :woot: :woot:
 

·
Registered
Joined
·
0 Posts
I have that same problem with my 2001 M3, I cruise on 1st and 2nd then punch it on 2nd and 3rd and the power of the car just doesnt respond the way it was, and it wont pass 4k RPM's it seems like some people are having the same problem but with different solutions some say Mass air sensor, Ignition Coils, Fuel Pump, Exhaust system. Is there a set problem that causes this or is it just one of all of those components that can be causing that problem
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top