E46 Fanatics Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 89 Results
  1. E46 General
    I have a 2001 330ci and my MAF was going bad and I tried cleaning it but last night I first had a couple episodes where I had rough idle and the engine would just fail so I waited a bit unplugged the MAF and it started and was going okay while I was trying to get home then on the highway I could...
  2. E46 General
    Guys, please help. Where should I start to get rid of p1188, p1189 car has very poor acceleration and feels so sluggish often. My intake boot is good no cracks. Im thinking about o2 sensors or maf. Oxygen sensors acting really weird. So bank 1 pre cat sensor voltage at idle stays steady at like...
  3. E46 General
    I have a 2001 BMW 325i with a manual trans, and I've been having this issue with my car where the idle bounces when I come to a stop light. I've already checked all the vacuum lines and have replaced most of them, and replaced the MAF. but I'm still having this bouncing idle, any ideas on what...
  4. E46 General
    Hello! Without stirring up the debate about when to replace a MAF sensor or the symptoms/behavior that might indicate this step, I'm trying to determine the manufacture date of the MAF in my vehicle. It came with no service records to speak of, and inspecting the part, it appears that the date...
    maf
  5. E46 General
    Hi everyone, I recently tried to start my car after having sat for three weeks to which it started but stalled out almost immediately. The car has never missed a beat up until this moment, it is serviced regularly and has just under 90k kilometers on the clock. After consulting roadside...
  6. Engine Swaps
    Hi guys, Been rebuilding a Z3 with the M54 3.0 swap. Guy who swapped engine before me did a piss job..... Anyways.... Which MAF are you guys using? I have two different brand new MAFs already but not sure if they will also work with the m52tu TB...
  7. E46 General
    Was going through maintenance on my 05 325 I got back in December. Fixed P0171+P0174, replaced the PCV valve plus the hoses, valve cover gasket, intake manifold gasket, all 6 plugs and a coil. Cars been fine for a week, until the CEL popped back on. Pulled the codes and it’s just P0174 by its...
  8. E46 General
    Hey guys, I recently got the P1500 “ICV Stuck Open” code on my 325ci which would put the car into limp mode within 5 min of driving but no difference to performance (no hard starts, idle issues, reduced economy, etc.). As I was taking apart the intake system, I found the MAF sensors connector...
  9. UK
    Hi guys, this one has me stumped, very confused as to why this is happening. have had poor fuel economy recently and due to increasing fuel comets here in the UK (and elsewhere!) I decided to replace my MAF as I had code for bad MAF. I have just done this no problems. Brand was BOSCH. went to...
  10. E46 General
    Hey everyone my car recently has been running perfectly with no codes on a ebay maf sensor that the previous owner bought for $18. I decided to buy a new one from fcp euro (VDO) and now all of a sudden my car is throwing all of these codes. Any ideas? I also did a smoke test for any vaccum leaks...
  11. E46 General
    Hello everyone. For me, the next step in the quest of living with a daily e46 as a broke student is trying to figure out what is going on with my idle. Today the car got flooded in the trunk (and I mean flooded like in a gallon of water inside the battery compartment). I sealed the place...
  12. E46 General
    Hi I have a 325ci and I’ve been having this issue for a while and after searching the internet I cannot find anything relevant to me. while driving at around 2000rpm and holing the throttle steady after about 5-20 seconds I get an EML light as well as traction control lights and limp mode...
  13. E46 General
    So about 6 months ago my maf went bad and my car was throwing up lean codes even though there was no vaccum leaks. A new maf later and my car was back up and running and no more codes. recently I’ve been getting a lot of odd electrical issues, and I’ve put it down to the alternator as it...
  14. E46 General
    Hello! I just bought my first bimmer. It's a 2001 325i. 161k miles.. I noticed that it was giving me MAF signals on my reader so I went to buy an MAF sensor. Before I installed it I noticed that the air intake boot behind the MAF was cracked completely in half. On top of that the tiny breather...
  15. E46 General
    Hi everyone, so these are the codes currently showing on my reader. Back in April this year I add these codes along with a P0170 and P0171. There was a very obvious misfire that you could feel and hear as well as a knocking sound coming from under the hood. In an effort to fix these codes I...
  16. E46 General
    Does anyone know a good source for these? I'm seeing "Genuine BMW" on ECS for $350, which feels obscene but I guess I'll do it if that's what everyone recommends.
  17. E46 General
    I've been trying to source lean codes for awhile now, I've spent plenty of time researching how to analyze fuel trims to see what the problem is. I recently smoke tested the car and could not find any leaks, however I took the intake manifold off, replaced the ccv and all associated gaskets...
  18. E46 General
    Hi! What is normal range of LTFT 1, LTFT 2 AND STFT 2. On ELM 327 with Torque pro- LTFT 1- -1,6%, LTFT2 - 0,8%, STFT2- 18,8% and MAF- 2,2 to 2,7g/s. This is when car is iddle, btw when i press gas pedal, rmps goes down, again when is in iddle. CAR:e46 320i 2001 automic 150ps, but in vehicle...
  19. E46 General
    I've read up on some discussions and have noticed that when your maf is going bad it typically reads lower... but that's not the case with my MAF. I currently have a P0171 code and have noticed that my MAF reads above 31 g/s upon acceleration or while on the highway. At idle it reads 3.7 g/s...
  20. E46 General
    Ok so I have 4 codes in my 2003 330i, P0174, P0171, P0420, and P0430. I’m pretty sure I need to replace my MAF because the live feed is under 3, my question is, should I be getting codes 430 and 420 because the vacuum leak or do I need to replace my sensors or cats?
1-20 of 89 Results
Top