E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!
crankshaft sensor
1-9 of 9 Results
  1. E46 General
    On my '03 325ci tonight my car cranked for just a second then the car cut the crank and all i heard was the fuel pump. I turned the key back off and then on again and the car started right up. I feel like its probably my crank sensor going bad but my question is if the crank sensor is going bad...
  2. E46 General
    Hey all, this is my first post here although I've been lurking the threads for longer than I've been a BMW owner. Anyway, I've run into a problem while resurrecting my 1999 328i. So recently I changed the CCV to an OCC, and upon restarting the car (first time the car had been started in...
  3. E46 General
    In desperate need of help, to save my sanity. Been chasing trouble codes/cold start issue for several months. First post but not new to the forum. 2000 323i wagon, 125,xxx miles -On cold start, cranks and fires..immediately dies. -Crank and start anywhere from 2-5 times while pumping gas...
  4. E46 General
    my car not ruining great rought idle, ruff start and code p0335. I changed that sensor and the check engine is still on. The idle is the most terible when A/C and/or defrost is on. Someone got this issu and solved it. Sorry for my english i speak french :p
  5. E46 General
    What's up guys, this is my first post and also the first BMW I have owned. I have a 2001 325i and it's been nothing but a nightmare. I have the code P0339 (crankshaft position sensor) I went ahead and replaced it with a autozone but it did nothing. So I returned it and ordered a OEM replacement...
  6. E46 General
    well my bmw wont start. ok i replaced the fuel pump and relays. it works and i get it running again. month later it doesnt crank at all just the starter cranking. i replaced the crankshaft position sensor and it almost fires up right now but a random mark appears next to the P on the instrument...
  7. E46 General
    please help!!! i'm new to this site and have an issue. right i bought a 2001 325ci vert, i bought it spares or repairs so problems were to be expected, i will start from the beginning, i saw it i loved it so parted with my cash, drove away in it, with an issue. it started idled really badly...
  8. E46 General
    Ok so ive had a cel light on for lean/rich codes sensor 1 bank 2, then I had more codes come up for all 4 o2 sensors, which is rather odd considering I have the active autowerks tune andhad the secondaries eliminated. Then I got a code for maf low signal on top of all these, it was like 6 or 7...
  9. E46 General
    Hi guys I'm going to quickly breakdown the problem. At first my car could beep then all the warning lights would come on. The problem persisted so i took it to a diagnostic and it was identified as a camshaft and crankshaft sensor problem. I changed the 2 camshaft sensors and for a while the...
1-9 of 9 Results
Top