E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

camshaft position sensor

  1. Europe
    So last Sunday I was driving my car and everything was normal and at once the the rpm dropped down to like 300rpm, and a clicking noise was coming from the fuse box, and when I press the gas pedal it goes to like 1500 rpm but then start to die. so I checked the codes and P0335 came out. so I...
  2. Europe
    Hello, I thinked my '99 323i E46 had less torque by moments so, i decided to pass a diag and no errors codes but wrong values at the camshaft position sensor, (intake). So, i bought an aftermarket sensor, (brand : Meat & Doria). After replacing all okay but now, i have some faulty sensor...
  3. General E46 Forum
    Hi guys, I have a 2001 e46 325ci with an m52tub28 engine (don't ask, old owner had if fitted as it was lower mileage). To add some context I've been overseas for the last 14 months and while away I got my brother to start it and warm it for me every so often. He doesn't have a licence so never...
  4. General E46 Forum
    Good Afternoon!!! I’ve bought a bit of a project (2004 318ci) with 95k It’s cranks but no start and has been like it since the drive belt (serpentine) snapped whilst driving, quickly pulled over then recovered by RAC. Manager to pull some codes... 2e97 - DME GENERATOR 2b62 - Camshaft Sensor 1...
  5. General E46 Forum
    Hi Everyone, My 2000 M52TU 323i started running extremely rough and stalling a few days ago. It would only stay running if I gave it a lot of gas. If I push in the clutch for example without giving it extra gas the engine will immediately die. I scanned the codes and I got: P1523 - 'A'...
  6. General E46 Forum
    Hello, guys! A month ago I had both camshaft sensors fail and my vanos unit developed a rattling. Few days ago I repaired the unit using beisan rattle/seals kit and changed both my sensors with second hand oem ones. Everything seems ok except if I stop the car and start it right away it picks up...
  7. General E46 Forum
    Hi all, I am getting the P1531 code on my 2001 330XI. According to the internet this is a problem with the intake camshaft position sensor, is this correct? I cleaned it today, but if it comes back, what's the next move? Buy a new one? Or could this have other origins? Cheers, fanatic
  8. General E46 Forum
    Read this code on my 2002 325i. Wondering where to start. Symptoms: SES light comes on after hard accelerations, then goes away after a day or two. Stalls like 1 or 2 times a month. Should I straight up replace the sensor? Or should I do some diagnosing first? I'm not sure where to start. I...
  9. ///M3 Forum
    So I just got done changing the intake camshaft sensor and coolant temp sensor on the M, and now I have a very rough idle, with it going as high as 2k, and all the way down to 500 rpm. It had also died a few times when I push the clutch in. It fits down to about 200 and then cuts off. I had the...
  10. ///M3 Forum
    Hello, Let me start with the obligatory "Sorry if I did not do good enough research, but I tried." I can't find anyone who has experienced this (or maybe I just don't know exactly what to search for). In short, a VANOS/Camshaft sensor issue seemed to come and then vanish in 3 days time...
  11. General E46 Forum
    My 328Ci is having periodic VANOS issues that is accompanied by a hard start (cranks for a little longer than usual about 4-5 seconds but starts every time) the car is down on power and it feels like the VVT is stuck in high rpm timing, the power below 3000 RPM is extremely poor and feels...
  12. General E46 Forum
    I have a 2000 328ci with 160,000 miles and The recent symptoms of my car in the past month are: -Stuck in fourth gear a few times along with CEL (now use steptronic daily to prevent this) -stalled out at a traffic light the other day when I let off the brake to start driving -rough idle and RPMs...
  13. General E46 Forum
    Hello, folks! Newbie here to the e46 forum, but anyway about a week ago I was replacing the jet sucking pump on my 2002 330Ci because of a vacuum leak I determined on a smoke test. I got the dreaded lean codes P0171 P0174 (Plus the thing broke on a very small tug.) Anywho, while I was taking...
  14. General E46 Forum
    Today I successfully replaced the oil separator and attached hoses in my 2003 325i. I'd read so many how-to's and watched quite a few videos, that it really made the process a lot easier. This and other forums as well as users posting to YouTube really made this attainable. The engine now is...
  15. General E46 Forum
    Hi New to the forum, I wondered if anyone knew what might be causing this, My car cut out when pulling off from a roundabout, All the lights came up, dtc, yellow handbrake light, and beeped. I pulled over after ruling a few things out disconnected the battery which I heard resets the ecu...
  16. General E46 Forum
    Hi! In the last 4 months I'm having a big trouble with a Inlet Camshaft Position Sensor in my 328i 99. I'm having the classic symptoms of a bad cam sensor: - Loss of power, stalling, difficult to start the engine. All of this symptoms comes up only with hot engine and it gets worse in hot...
  17. General E46 Forum
    So, I have a 2000 BMW 323ci during the weekend I was driving back home when my car started to sputtering. It lost power and the engine died on me, ever since then my engine turns but it doesn't start unless I spray carb cleaner into the mass airflow sensor. I checked for an air leakage and fuel...
  18. General E46 Forum
    My '01 325i service engine light came on. Codes indicated problem was intake camshaft position sensor. Had indie shop replace both intake and exhaust sensors. Now the car feels flat, like it has lost significant power. Seems to be especially obvious in 2nd gear. Also had fuel filter changed...
  19. General E46 Forum
    Hi! I hope i´m posting in the corect section. (FYI, I have limited experience with engine mechanics). I recently bought a BMW 318 -03 with the N42 engine that seemed to be in good condition with only 13800km (22000 miles) on the clock. Engine running fine on idle and no powerloss on...
  20. E46 Xi Forum
    My car is stalling when idle. I've cleaned the MAF sensor, replaced the Oil Separator with all new hoses, cleaned the ICV and removed the broken flap of the DISA until the new one arrives on the mail. I also replaced the lower intake boot, since it was in fact broken on the elbow. After doing...
Top