Oil light and Coolant light - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 5 votes, 5.00 average. Display Modes
Old 01-22-2010, 10:56 AM   #1
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,344
My Ride: not an E46
Oil light and Coolant light

There has been an ongoing problem with my car since December regarding the coolant light and the oil light (yellow).
I am creating this thread for documentation purposes as well as getting help.

One day in early December, I noticed the yellow oil light come on. I checked my oil level and it turned out to be normal (halfway mark). I bought a quart of oil and poured in half just incase. Rechecked oil level and it was slightly below the max mark. Yellow oil light turned off.
A day later, the light came on again... rechecked oil level and it was exactly the same as before. I searched online and found out its most likely the oil level sensor since they go bad all the time. I thought it wasnt a big deal, I'll just live with it for now, since I know my oil level is normal.
2 weeks later, the temps dropped to about 4 degrees for about 2 weeks. Yellow oil light has been going on and off. This time, coolant light came on. I thought it wasnt a problem either, since my Jettas do this in extreme cold weather as well, and then the light turns off after a couple mins. Same situation with my E46.... coolant light came on, then turned off after a couple mins.
As the days progressed, the coolant light stayed on longer and longer, and this time it was periodically coming on and off even while driving. Yes I know it was stupid that I did not check my coolant level in the beginning. I ignored it because my reasoning was that if the light goes off, then there is no problem because by then I should have lost all my coolant. I always kept my eye on the coolant temp guage, which always stayed dead center, no matter what. Eventually I checked the coolant level, and found it to be just a tad bit low and I topped off with water. Coolant light did not come back...
One day, I decide to do a compression test just for kicks. I find low compression and also oil on spark plugs. I knew that wasnt a good sign. I check oil level and it was dangerously low. I searched for possible causes which were VCG, oil separator, head gasket. I topped off oil, replaced VCG which was really hardened and leaking in some areas. I found rips in the CCV's hoses... I plugged them up as a temporary fix. Oil and coolant lights still did not return.
A week after the VCG, the coolant light returns as well as oil light. I check oil level, and it was a tad bit over min line. Last time I topped off it was in the exact middle of min and max lines. I check coolant level and it was low again. I added water until the stick rose... it took half a gallon of water. I searched frantically for coolant leaks, could not find anything. Removed intake hoses etc to see the coolant hoses and expansion tank... nothing. Did the test before driving and after driving... still no visible leak. Not a good sign. Feeling really scared and sad right now, I decide to bring it to the shop next time around. It should be noted that I hear funny noises that describe a failing CCV (chewbacca/cow/sea lion mating call, or groaning noises). All other symptons seem to fit, such as oil on plugs and gas cap suction test.
Coolant light and oil light stayed off for 4 days.... when they came back on again (last night) I bought some BMW coolant and topped off and also topped off oil (1/3 of quart lost). I was finally able to bring the car to the shop today. The mechanic checked my car, and could not find any leaks in the VCG. He could not find any coolant leaks anywhere... nor any oil leaks. Its not looking good for me right now (head gasket symptoms). He asked me if I smell something funny, and I said that I have a bad sense of smell. Before I topped off coolant, I noticed lots of spillage around my coolant cap... I pointed it out to him, and he said that he cant be sure that its coolant. I went ahead and bought a new coolant cap and I'm about to install it. I'm hoping that would solve the cooling system problem. As for the oil problem, I'm sure its at least the CCV.... but it could also be the head gasket.
If the coolant cap does not fix the coolant problem, then its definitely head gasket, since there was NO signs of leakage anywhere except gas cap. The coolant leak is a slow leak, it takes about 4 days for the coolant light to come on. So I will know next week what it is.

Yes I know about the cooling system overhaul and that I should do it... but I dont want to replace my entire cooling system yet, only to find out its my head gasket. The radiator and expansion tank were replaced 22k miles ago. The hoses look as good as new. As for the oil problem, I think I will try to install a catch can system in the mean time... the mechanic quoted me 4 hours and I do not want to pay for 4 hours of work yet... nor do I want another faulty valve that will go bad again. I'm still searching for the catch can parts.
__________________
mujjuman

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2003 330xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 01-22-2010, 12:44 PM   #2
ECSTuning
Registered User
 
ECSTuning's Avatar
 
Join Date: Jul 2008
Location: Wadsworth, Ohio
Posts: 13,148
My Ride: BMW
Sensor failure is very common on our cars. I have replace my coolant temp sensor 3 times.

We have both replacements available below.

Oil Level Sensor
Click HERE to order or for more information.



Coolant Level Sensor
Click HERE to order or for more information.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 |
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ECSTuning is offline   Reply With Quote
Old 01-22-2010, 01:42 PM   #3
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,344
My Ride: not an E46
Thank you. My coolant is actually leaking though... Either leaking or burning. Or both.
__________________
mujjuman

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2003 330xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-22-2010, 01:56 PM   #4
ECSTuning
Registered User
 
ECSTuning's Avatar
 
Join Date: Jul 2008
Location: Wadsworth, Ohio
Posts: 13,148
My Ride: BMW
Quote:
Originally Posted by mujjuman View Post
Thank you. My coolant is actually leaking though... Either leaking or burning. Or both.
Then your real best bet is going to be a refresh of the system. If you have not done your water pump, now might be a good time. Seeing that you did do your radiator and expansion tank, you might want to consider finishing the system replacement. I can not speak with out seeing the car, but its not likely it is your head gasket.

We offer Cooling system refresh kits in Level I & II

Click HERE to order or for more information.


We can also create custom link with specific parts you would like, since you would not need the expansion tank.

Let me know if you have any questions!
Joe
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Customer Service Hours: M - F 8:00am - 8:00pm EST | Saturday: 10:00am - 7:00pm EST
Sales Team Hours: M - F 8:00am - 11:00pm EST | Saturday: 10:00am - 7:00pm EST
800.924.5172 |
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
ECSTuning is offline   Reply With Quote
Old 01-22-2010, 02:24 PM   #5
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,344
My Ride: not an E46
Quote:
Originally Posted by ECSTuningJoe View Post
Then your real best bet is going to be a refresh of the system. If you have not done your water pump, now might be a good time. Seeing that you did do your radiator and expansion tank, you might want to consider finishing the system replacement. I can not speak with out seeing the car, but its not likely it is your head gasket.

We offer Cooling system refresh kits in Level I & II


We can also create custom link with specific parts you would like, since you would not need the expansion tank.

Let me know if you have any questions!
Joe
thanks for the link. yeah i hope its not my H.G.
i'll def check the prts out

[edit]

wait whats the difference b/w level 1 and 2?
__________________
mujjuman

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2003 330xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 01-25-2010, 10:25 AM   #6
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,344
My Ride: not an E46
Car is at the shop now, waiting to be looked at.
I tried to see if I would have oil in the intake manifold, and the hose was so brittle that it broke. Now, because of a vacuum leak as a result of the broken hose (or other issues... hopefully not), the car wont stay running for more than 1-3 secs. I tried to temporarily remedy this situation by taping the hose but it didnt work. I had to get the car towed as a result. $152.
__________________
mujjuman

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2003 330xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 01-25-2010, 12:09 PM   #7
Bartacus
Registered User
 
Join Date: Apr 2002
Location: Ottawa, Ontario, Canada
Posts: 3,270
My Ride: 2002 320i Sedan
I think you're making the right move by waiting for a proper diagnosis BEFORE spending tons of money on the cooling system. I had mine COMPLETELY replaced over the past year (total: around $2200CDN). And I only NOW discover that I might have a hairline crack in the cylinder head. So it appears all that money might have been wasted.
Bartacus is offline   Reply With Quote
Old 01-25-2010, 01:39 PM   #8
mujjuman
Registered User
 
Join Date: Jun 2008
Location: New York
Posts: 3,344
My Ride: not an E46
Wow sorry to hear about your problem!
But yeah I don't see the need to blindly replace the entire cooling system when the problem can be something else. I like to rule out all other options before spending all that money... Only to find out that it was unnecessary.
__________________
mujjuman

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

2003 330xi 5MT
Jet Black, ZSP, ZPP, ZCW, OEM Xenon ^^RIP
sig by Solidjake
mujjuman is offline   Reply With Quote
Old 11-20-2011, 06:39 PM   #9
DJ RaMiN
Registered User
 
Join Date: May 2007
Location: Bay Area
Posts: 5,711
My Ride: 02 325I,03 M3
so what was the problem?
DJ RaMiN is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 07:23 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.