Couple of Codes... what to replace? - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 09-13-2007, 11:52 PM   #1
snoopnoon
 
Join Date: Jul 2007
Posts: 16
Couple of Codes... what to replace?

Ok guys, i have just purchased my car a month ago. It has been running awsome and is in mint condition. Car is a 2001 330XI.

Problem: Service engine soon light came on:

Code 1) Camshaft pos sensor Bank 1

Code 2) P0109 Manifold Absolute Pressure/Barometric Pressure Circuit Intermittent


Any advice on what to fix? I am pretty hands on so any help on what parts could be malfunctioning would be helpful

Thanks
Adam
snoopnoon is offline   Reply With Quote
Old 09-14-2007, 12:08 PM   #2
snoopnoon
 
Join Date: Jul 2007
Posts: 16
bump
snoopnoon is offline   Reply With Quote
Old 09-14-2007, 12:32 PM   #3
white46
Registered User
 
Join Date: Feb 2006
Location: Vancouver Canada
Posts: 1,990
My Ride: e46 323ci
for "Camshaft pos sensor". not quite sure whether bank 1 is exhaust side or intake side.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
white46 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-14-2007, 04:55 PM   #4
snoopnoon
 
Join Date: Jul 2007
Posts: 16
Thanks for all your help .. i did not know which sensor to replace so i bought them both.. I replaced the easiest first (exhaust) and light went off.

Surprising my car only has 58K on it
snoopnoon is offline   Reply With Quote
Old 09-15-2007, 12:38 AM   #5
snoopnoon
 
Join Date: Jul 2007
Posts: 16
Ok ..well it was fixed. it ran beautifull for about half the day. I went to start it later today, failed to start, then started but went into limp mode again with the same type of problems as before. Any idea's?
snoopnoon is offline   Reply With Quote
Old 09-15-2007, 12:44 AM   #6
deafboy
Registered User
 
Join Date: Sep 2005
Location: Blaine, WA
Posts: 26,609
My Ride: 2000 323Ci
out of warranty?
__________________
-Cole aka bigtall*****
-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
-
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
-

Quote:
You'll always be pretty in my eyes, Cole :luv:
Quote:
i was like passed out while she's shoving the entire bar in my mouth. :rofl: :rofl:
deafboy is offline   Reply With Quote
Old 09-15-2007, 12:48 AM   #7
KrisL
Registered User
 
Join Date: Dec 1969
Location: San Jose, CA
Posts: 1,205
My Ride: 03 330i ZHP
Send a message via AIM to KrisL
Well if you have two, try replacing the other one?

The other code makes me think you have a vacuum leak somewhere in your intake system.

Look for something like this..
__________________
330i ZHP

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
KrisL is offline   Reply With Quote
Old 09-15-2007, 03:21 AM   #8
snoopnoon
 
Join Date: Jul 2007
Posts: 16
I have 60K on an 01 i beleive that is out of warrenty? I am second owner.

I got a detailed code for the second one it is

MAP cooling intermitent low
snoopnoon is offline   Reply With Quote
Old 09-20-2007, 01:19 PM   #9
markusmark
 
Join Date: Aug 2003
Posts: 1,679
For CSPS: "Bank" 1 is the intake sensor.

For O2 sensors: Bank 1 is cylinders 1, 2, 3; Bank 2 is cylinders 4, 5, 6.
markusmark is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 10:00 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.