E46 2006 vert with Gm transmission issue - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-19-2017, 08:22 PM   #1
Droptopbmw
Registered User
 
Join Date: Sep 2017
Location: Georgia
Posts: 42
My Ride: 2006 330
E46 2006 vert with Gm transmission issue

My vert with the Gm transmission has a weird problem in sports mode. I can drive all day in regular mode without any issues. If I switch to sport mode the transmission will get stuck in 3rd gear and I will be in really high rpm. That's if I floor the throttle all the way . Then if I drive normal on sport mode I can get all the way up to 4th gear sometimes and it'll be there for a good bit . When it's in high rev in sports mode , I can simply switch back to drive and the rpm will drop and transmission shift normally back up to 5th. If it's in fourth and I floor it , the transmission will lockdown and stay in 3rd for a long time until it decides to shift. I haven't try to wait as of yet when it's in 3rd at 6k plus rpm. The car sounds normal and it shift normal in regular d mode. If anyone who knows about the GM transmission please share some advice .
Droptopbmw is offline   Reply With Quote
Old 11-20-2017, 03:02 AM   #2
NumbaOneNewb
Registered User
 
Join Date: Jul 2012
Location: Portland, OR
Posts: 3,424
My Ride: 2003 330CI Silver
I always thought that I sport mode, it's supposed to stay in gear even if that means revving up in the high rpm range.

Would be similar to someone in a manual transmission leaving it in 3rd and keeping the revs high.

Sounds normal to me
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Portland Metro: ECU updates, Euro tune, euro corner delete, air bag light, DSC light, cluster and any led color change, soldering work, transponders for keys, and all custom work related to computer or electronics.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
NumbaOneNewb is offline   Reply With Quote
Old 11-20-2017, 06:47 PM   #3
Droptopbmw
Registered User
 
Join Date: Sep 2017
Location: Georgia
Posts: 42
My Ride: 2006 330
In sports mode meaning sd , I think you're talking about manual mode. In sports mode it never did that before . The only thing diffrent between sports and regular is the gears are held longer. It should still change gears when the throttle is changing to a lower position . I'm almost sure that the transmission is communicating with the speed sensor and maf to make a decision when to change gears. I been a mechanic for over 20 years . The strange thing is it only does this in sports mode and drives normal in regular d mode. I notice one other thing is when I slow down there's a jerk while coming to stop . It's almost like the transmission downshift late and hard to deccelerate. This is a symptom of low transmission fluid . I used to be a member of roadfly long ago when I own a 2001 740i sports . A member had diffrent tire size and it screw up his transmission shifting. The sensor per wheel was reporting diffrent tire revolution so it was confusing the control module. I also had a tire pressure light go on since this started. One of my tire is 225/35/19 on the front and the other front is 235/35 which do look a little taller.
Droptopbmw is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-21-2017, 07:28 AM   #4
markusmarkus
Registered User
 
Join Date: Jul 2008
Location: USA
Posts: 9,326
My Ride: 2018 M240i
Id have the engine computer (DME) and the tranny computer (EGS) scanned for codes. The SES light is on only when an emissions related code is present.
markusmarkus is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 06:29 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.