DME software version - E46Fanatics E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 11-16-2017, 10:32 PM   #1
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
DME software version

I fired up PA Soft for the first time today to have a look at my DME software version. I had some misfire issues a few months back and jfoj recommended a reflash based on how my advance and fuel trims were behaving. Behavior seemed to improve but my issues are clearly not resolved; maybe they just cleared out some crappy adaptations that had built up?

I paid an indie shop (bmw only) but they seemed a little mystified by my request for a reflash, and when I picked it up they charged me $149 and claimed that the software didn't have no version number but they had upgraded me to what was most def the latest and greatest...

My first PA soft log seems to tell a different story. No update from the original version, and not the 7561520 that I've seen recommended in these forums. Here's the excerpt from the log:

# USER INFO FIELDS
---------------------------------------------------------------------------------------------------------------------------
Unit Date VIN Odometer Assembly Software Service Dealer Tester Program ver.
---------------------------------------------------------------------------------------------------------------------------
DME* -> 07.03.06 WBABW53456PJ97604 0 km 7.562.334 7.562.335 0.000.000 012321 42324 0044570LO00S
18.09.17 WBABW53456PJ97604 121800 km 7.562.334 7.562.335 0.000.000 011111 12345 0044570LO00S

which seems to show version 7562335 originally installed March 7 2006, left unchanged in the only other record on September 18 of this year. Am I reading that correctly? Is my current version 7562335? And should I have version 7561520 instead? It's a 2006 330 cic ZHP 6 speed. It seems strange that a newer version would have a lower version number.

Can't wait to explore PA Soft some more...
aaalbedo is offline   Reply With Quote
Old 11-16-2017, 10:36 PM   #2
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
Whoa, bad alignment. In the text file it aligns like this:

Date...............Software
07.03.06........7.562.335
18.09.17........7.562.335
aaalbedo is offline   Reply With Quote
Old 11-17-2017, 05:35 AM   #3
BaliDawg
DEADBEEF BAADF00D
 
BaliDawg's Avatar
 
Join Date: Aug 2012
Location: Riverside, CA
Posts: 9,146
My Ride: E39 E46 E84
Quote:
Originally Posted by aaalbedo View Post
Whoa, bad alignment. In the text file it aligns like this:

Date...............Software
07.03.06........7.562.335
18.09.17........7.562.335
Your car came from the factory with the latest version. BMW never made newer versions for E46 after end of production.

Your Indy simply flashed in the same version that was already there, which was a useless thing to do!

The DME software is not your problem.
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
BaliDawg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-18-2017, 01:42 PM   #4
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
Thanks, BaliDawg. What I was afraid of...

It does seem like I have some DME irregularities; below is just a snapshot, but it seems like my LTFT is adjusting way too fast, as if it is not able to save data in its records and can only work with very recent data to calculate LTFT which seems like it should change much more gradually. In the plots below collected during warm idle, you can see LTFT changing just as fast as STFT, both cycling dramatically (and opposing/compensating one another) on about a 17 second pattern. Much, much more information is in my other post, warm misfires redux.

PA soft did report a few DME errors so I'll start digging in to those. From what I've read many errors that PA soft reports are not worth worrying about, but this will be my first use of that data so lots and lots yet to learn.


aaalbedo is offline   Reply With Quote
Old 11-18-2017, 01:51 PM   #5
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC

aaalbedo is offline   Reply With Quote
Old 11-18-2017, 01:53 PM   #6
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
Huh. The forum doesn't seem to like Dropbox URLs to embed images, it just leaves blanks. More learning needed...

https://www.dropbox.com/s/f7dg03xlzl...0trim.jpg?dl=0
https://www.dropbox.com/s/k67uewtbe0...trims.jpg?dl=0
aaalbedo is offline   Reply With Quote
Old 11-19-2017, 05:50 AM   #7
NumbaOneNewb
Registered User
 
Join Date: Jul 2012
Location: Portland, OR
Posts: 3,424
My Ride: 2003 330CI Silver
Depending on how the flash it, it could also be that when flashed the version number was not being written over.

Forgive me if I'm speaking incorrect info. It's been awhile since I've worked with flashing dme.

Is there a reason you're flashing software?
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Portland Metro: ECU updates, Euro tune, euro corner delete, air bag light, DSC light, cluster and any led color change, soldering work, transponders for keys, and all custom work related to computer or electronics.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
NumbaOneNewb is offline   Reply With Quote
Old 11-19-2017, 07:04 AM   #8
BaliDawg
DEADBEEF BAADF00D
 
BaliDawg's Avatar
 
Join Date: Aug 2012
Location: Riverside, CA
Posts: 9,146
My Ride: E39 E46 E84
Quote:
Originally Posted by NumbaOneNewb View Post
Depending on how the flash it, it could also be that when flashed the version number was not being written over.

Forgive me if I'm speaking incorrect info. It's been awhile since I've worked with flashing dme.
Nah, if UIF write was unchecked it wouldn’t have even created a new record when it was flashed. The fact that a second record is there with the recent date indicates UIF write was checked before flashing.
https://www.ecuworx.co.uk/wp-content...6/02/smg04.jpg
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
BaliDawg is offline   Reply With Quote
Old 11-19-2017, 09:22 AM   #9
NumbaOneNewb
Registered User
 
Join Date: Jul 2012
Location: Portland, OR
Posts: 3,424
My Ride: 2003 330CI Silver
I see No better version than the 7562334 for that car
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Portland Metro: ECU updates, Euro tune, euro corner delete, air bag light, DSC light, cluster and any led color change, soldering work, transponders for keys, and all custom work related to computer or electronics.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
NumbaOneNewb is offline   Reply With Quote
Old 11-19-2017, 10:38 AM   #10
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,904
My Ride: 330CiC, M5, X5, E93
aaalbedo sorry if there are no new DME flashes available, I do not have a list and I would have hoped that a shop would have been able to confirm if the car had the latest and greatest DME flash before they bothered to do any further work.

Balidawg probably knows better than me, but just because a model has come to the end of production does not mean there are no newer DME updates. If there is a list somewhere that outlines the newest DME flashes, this would be useful to have posted. I have not confirmed this 100% but it does look like on some of the later models OBDFusion does show the DME flash? I assume BMW Scanner and INPA can also provide this info?

As for the ignition timing, it does look like there is a problem with your car from the initial Logs. You may need to only Log the Timing, RPM, Throttle Position and MAF values and then load the car under 3000 RPM and run some test drives to get a better view of the Ignition timing. While other factors could cause ignition timing issues, BMW is known for problematic ignition timing Maps in a number of models over many years.

While you provided a few graphs of the Fuel Trim and Timing, it is unclear if these were from your car and posting a single graph without the raw data or .CSV file is dangerous. The is no context under what driving conditions these graphs were generated under. So while the graphs may show something unusual without a clear understanding under what conditions these were captured, it is a bit useless to make assumptions.

Maybe BaliDawg or someone can confirmed that the DME flash you have is actually the most current version and was it the original version or was it already updated at some point? What is the build date of your car? You can run your VIN through a number of BMW VIN Decoders and some will actually give the build date and not just the build Month and Year. Seems the latest build month for 2006 Coupes was in May??
__________________
Solve your misfires, lean codes, rough idle -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Fuel pump failures -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Temp Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Hidden OBC Menu - Check Voltage, Temp, Fuel Level -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


E46/E39 GM5 Door Lock Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Lower hose temp switch O-ring - BMW #13621743299

Last edited by jfoj; 11-19-2017 at 10:41 AM.
jfoj is offline   Reply With Quote
Old 11-19-2017, 10:43 AM   #11
NumbaOneNewb
Registered User
 
Join Date: Jul 2012
Location: Portland, OR
Posts: 3,424
My Ride: 2003 330CI Silver
I just checked. Shows to be the most recent version
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Portland Metro: ECU updates, Euro tune, euro corner delete, air bag light, DSC light, cluster and any led color change, soldering work, transponders for keys, and all custom work related to computer or electronics.
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
NumbaOneNewb is offline   Reply With Quote
Old 11-19-2017, 11:05 AM   #12
BaliDawg
DEADBEEF BAADF00D
 
BaliDawg's Avatar
 
Join Date: Aug 2012
Location: Riverside, CA
Posts: 9,146
My Ride: E39 E46 E84
Quote:
Originally Posted by jfoj View Post
aaalbedo sorry if there are no new DME flashes available, I do not have a list and I would have hoped that a shop would have been able to confirm if the car had the latest and greatest DME flash before they bothered to do any further work.

Balidawg probably knows better than me, but just because a model has come to the end of production does not mean there are no newer DME updates. If there is a list somewhere that outlines the newest DME flashes, this would be useful to have posted. I have not confirmed this 100% but it does look like on some of the later models OBDFusion does show the DME flash? I assume BMW Scanner and INPA can also provide this info?

As for the ignition timing, it does look like there is a problem with your car from the initial Logs. You may need to only Log the Timing, RPM, Throttle Position and MAF values and then load the car under 3000 RPM and run some test drives to get a better view of the Ignition timing. While other factors could cause ignition timing issues, BMW is known for problematic ignition timing Maps in a number of models over many years.

While you provided a few graphs of the Fuel Trim and Timing, it is unclear if these were from your car and posting a single graph without the raw data or .CSV file is dangerous. The is no context under what driving conditions these graphs were generated under. So while the graphs may show something unusual without a clear understanding under what conditions these were captured, it is a bit useless to make assumptions.

Maybe BaliDawg or someone can confirmed that the DME flash you have is actually the most current version and was it the original version or was it already updated at some point? What is the build date of your car? You can run your VIN through a number of BMW VIN Decoders and some will actually give the build date and not just the build Month and Year. Seems the latest build month for 2006 Coupes was in May??
He has the latest. The later production E46s I've seen came from the factory with the latest version.

My update thread has the MS45.1 history file at this post.
https://forum.e46fanatics.com/showpos...2&postcount=87

The MS43, GS20, and GS8.60 are in that thread as well.
MS43: https://forum.e46fanatics.com/showpos...0&postcount=86
GS20: https://forum.e46fanatics.com/showpos...9&postcount=85
GS8.60: https://forum.e46fanatics.com/showpos...&postcount=119
__________________

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Last edited by BaliDawg; 11-19-2017 at 11:08 AM.
BaliDawg is offline   Reply With Quote
Old 11-19-2017, 09:02 PM   #13
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
Lots of great contributions here! This forum is such a great resource. Three sources (two here and the indie shop) would suggest that I do have the latest version of software.

This is a 6 speed ZHP convertible, but I'd imagine production ended about the same time as the coupe. Build date from one of the online vin decoders says 2006 March 6. The BMW Scanner log does show the software version in the log that is generated whenever you run a scan, and my log says the DME was first flashed March 7 2006, the day after build, and then again in September with the same version 7562335. Is that reasonable, flash the day after build?

Searches within the forum and on the wide wide world of web showed no useful results for searches on this software version when combined with terms like e46 or even bmw. Before I had the indie reflash, the best I could come up with was version 7561520 but I had low confidence in that, and in retrospect it probably applies for earlier non-wideband O2, non-MAF controlled SAP, less wires MAF ZHPs. So a consolidated table as jfoj suggests showing latest versions for the various models would be an excellent idea.

As an aside, a similar compilation fo obdfusion logs from "good" cars would also be very helpful. I've been waiting for my car to get good so that I can record just such a baseline set for myself and would be happy to share if I can get there. Lots of examples of logs from cars with problems, but it would be very helpful to see "normal" fuel trims, MAF flows, timing variations, etc etc.

And as to motivation for the flash... long story. This is a low mile car that I bought 2 years ago at 62k miles or so, and the plan is to turn it into a reliable bone stock DD/winter car for the next 10 years. And "reliable" is relative; my summer/dry winter days DD is a 33 year old Pininfarina Azzura (fiat spider). Later this week I will be pulling the transmission for the fourth time in 3 years.

The BMW came from an Accura dealer with zero records, so I've assumed everything was original and have been updating accordingly. And I've erred cautious; throttle body threw codes and MAF showed some preliminary indications of soft fail, so I replaced both. Worst case I have spares. I haven't touched brake booster or Vanos, but I'm doing cooling system/belts/tensioner/pump/thermostat this week, and cam sensors while I'm there. Every other system has been replaced with OEM or BMW.

But I have a persistent/intermittent issue that really seems DME related. Before the flash, this log shows the DME driving wilder and wilder timing and fuel trim swings, STFT flatlines at -28% for a while, then the DME gives up and goes into open loop fault (status 8) and STFT goes back to zero. Somewhere in all of this, misfires begin, DME throws pending misfire codes for cylinder 5 then the rest of bank 2, and the car starts blowing lots of unburnt fuel through the cats. Never more than a pending code, never a fuel cut, and no other codes at all. Let it cool down overnight and it's like it never happened, although it starts a bit rough.

https://www.dropbox.com/s/5t81b6k1g3...iming.xls?dl=0

The flash seemed to improve things; events described above became a lot less common. So maybe part of the flash was to delete some bad adaptations that had accumulated? Since the reflash the misfire/smoke fault has happened only three times in 2 months (it was nearly daily before), but now I can see that the DME still struggles (this file is the source of the jpg snapshot graphs above)

https://www.dropbox.com/s/d619758vh1...rims.xlsx?dl=0

So it seems like my LTFTs are way too volatile, as if the DME is not able to store new data and has to calculate only on short term data; I would not expect that LTFT would be able to cycle as fast as STFT. But beyond that I have no ideas. Maybe wait until after I get the cam sensors swapped and cooling system replaced?

Thanks for any other ideas to pursue...
aaalbedo is offline   Reply With Quote
Old 11-19-2017, 10:36 PM   #14
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,904
My Ride: 330CiC, M5, X5, E93
While the DME flash may have been the same file number, something does not look very good at first glance.

You indicated the new flash has less power, well when the ignition timing maxes out at around 18 degrees, this is about 14-18 degrees short of where the ignition timing should operate. You can feel a loss of 2-3 degrees of timing, 14-18 degrees will be a MAJOR loss of power.

I need to think about this case and look at some of the data provided.

Best to move the graphs to another page as to no clutter up the .CSV file page, easy to do.

So the question is does the car have a bad DME, bad RAM module on the DME or something else going on? Reflashing should not have cut the timing, wondering if you may have to reflash with an earlier DME version but this may be VIN controlled??

Need someone with the ability to access the DME files and graph out the timing Map, not sure this is something many people can do.
__________________
Solve your misfires, lean codes, rough idle -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Fuel pump failures -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Temp Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Hidden OBC Menu - Check Voltage, Temp, Fuel Level -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


E46/E39 GM5 Door Lock Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 11-19-2017, 10:52 PM   #15
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 8,552
My Ride: 2002 325i
Quote:
Originally Posted by jfoj View Post
While the DME flash may have been the same file number, something does not look very good at first glance.

You indicated the new flash has less power, well when the ignition timing maxes out at around 18 degrees, this is about 14-18 degrees short of where the ignition timing should operate. You can feel a loss of 2-3 degrees of timing, 14-18 degrees will be a MAJOR loss of power.

I need to think about this case and look at some of the data provided.

Best to move the graphs to another page as to no clutter up the .CSV file page, easy to do.

So the question is does the car have a bad DME, bad RAM module on the DME or something else going on? Reflashing should not have cut the timing, wondering if you may have to reflash with an earlier DME version but this may be VIN controlled??

Need someone with the ability to access the DME files and graph out the timing Map, not sure this is something many people can do.
Jfoj I believe you can map them out with tunerpro + an xdf. You can check out the ms43 tuning thread for more info. I haven't done it myself but I do know that there is a mapping feature
https://forum.e46fanatics.com/showthread.php?t=1082287
armenh7 is offline   Reply With Quote
Old 11-19-2017, 11:02 PM   #16
jfoj
OEM ///Member
 
Join Date: Nov 2009
Location: Fairfax, VA USA
Posts: 28,904
My Ride: 330CiC, M5, X5, E93
I think the problem is this car is a MS45.
__________________
Solve your misfires, lean codes, rough idle -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Fuel pump failures -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Temp Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Hidden OBC Menu - Check Voltage, Temp, Fuel Level -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


E46/E39 GM5 Door Lock Info -
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Lower hose temp switch O-ring - BMW #13621743299
jfoj is offline   Reply With Quote
Old 11-19-2017, 11:03 PM   #17
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 8,552
My Ride: 2002 325i
Quote:
Originally Posted by jfoj View Post
I think the problem is this car is a MS45.
That makes it more difficult. There are companies out there that have disassembled it but we don't have the information publicly available
armenh7 is offline   Reply With Quote
Old 11-21-2017, 11:42 AM   #18
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
I compiled a number of data files that were collected while driving (no straight idle files). Most are just driving to work and back. My route has no stop and go, and has sections where I can get it up a bit past 60 on either route I can take. The data is stacked by date. I filtered out everything below 1300 rpm in the "1300 rpm" tab and re-ordered sequentially, but it doesn't look much different than the "All" tab which includes idling and engine off time as well. There's a vertical line where the DME was reflashed.

https://www.dropbox.com/s/fti6ofviox...lash.xlsx?dl=0

There doesn't appear to be a change with the reflash, so maybe the perceived difference was imaginary. At most it was a 5 or 10% drop in power and didn't seem related to RPM; I'd think that if my timing were restricted it would be most noticeable at higher RPM. The frequency of smoky misfires definitely dropped after the reflash, but as the events seemed to correlate with warm drives on warm days with stop and go traffic, it is just as likely that it just rarely saw the conditions that triggered the fault as the weather cooled.

The timing maxes out at 36 degrees in this extended data set and spends a fair bit of time above 30 degrees, so maybe you were just looking at a limited period when the timing didn't exceed 18 degrees, jfoj?

I want to collect some more data after the cooling system and cam sensors are done (should be today) because I'm wondering if there might be Vanos trouble, and I expect the cam sensors are involved there. I have yet to read up on how Vanos even works but I have two indicators that say there might be trouble. First, during one of the first times I was ever able to catch a misfire event in the act with OBDFusion, I saw a step change while idling warm; air flow suddenly doubled while RPM dropped. It didn't seem reasonable that air flow could change that much without a big change in valve durations, but maybe a sticky ICV could also explain that. Which reminds me that I want to clean the ICV today while I have the cooling system out.

https://www.dropbox.com/s/js93rwlj0d...0921.xlsx?dl=0

Second was just engine sound; here are a couple of movies taken at cold idle and warm idle. Cold idle sounds fine, warm idle sounds diesely and the sound is definitely coming from the timing chain area. I have no idea if either of these could be related to Vanos issues.

https://www.dropbox.com/s/uf1tnorfvf...ected.MOV?dl=0

https://www.dropbox.com/s/rskud0kbiu...%20O2.MOV?dl=0

If a bad DME is indicated, I'm prepared to go new; I think there's an online source for about $800. Not inclined to take my chances with junkyard roulette at this point, although the DME does seem to be generally pretty robust. Thoughts?
aaalbedo is offline   Reply With Quote
Old 11-21-2017, 11:58 AM   #19
armenh7
Registered User
 
Join Date: Dec 2016
Location: California
Posts: 8,552
My Ride: 2002 325i
Quote:
Originally Posted by aaalbedo View Post
I compiled a number of data files that were collected while driving (no straight idle files). Most are just driving to work and back. My route has no stop and go, and has sections where I can get it up a bit past 60 on either route I can take. The data is stacked by date. I filtered out everything below 1300 rpm in the "1300 rpm" tab and re-ordered sequentially, but it doesn't look much different than the "All" tab which includes idling and engine off time as well. There's a vertical line where the DME was reflashed.

https://www.dropbox.com/s/fti6ofviox...lash.xlsx?dl=0

There doesn't appear to be a change with the reflash, so maybe the perceived difference was imaginary. At most it was a 5 or 10% drop in power and didn't seem related to RPM; I'd think that if my timing were restricted it would be most noticeable at higher RPM. The frequency of smoky misfires definitely dropped after the reflash, but as the events seemed to correlate with warm drives on warm days with stop and go traffic, it is just as likely that it just rarely saw the conditions that triggered the fault as the weather cooled.

The timing maxes out at 36 degrees in this extended data set and spends a fair bit of time above 30 degrees, so maybe you were just looking at a limited period when the timing didn't exceed 18 degrees, jfoj?

I want to collect some more data after the cooling system and cam sensors are done (should be today) because I'm wondering if there might be Vanos trouble, and I expect the cam sensors are involved there. I have yet to read up on how Vanos even works but I have two indicators that say there might be trouble. First, during one of the first times I was ever able to catch a misfire event in the act with OBDFusion, I saw a step change while idling warm; air flow suddenly doubled while RPM dropped. It didn't seem reasonable that air flow could change that much without a big change in valve durations, but maybe a sticky ICV could also explain that. Which reminds me that I want to clean the ICV today while I have the cooling system out.

https://www.dropbox.com/s/js93rwlj0d...0921.xlsx?dl=0

Second was just engine sound; here are a couple of movies taken at cold idle and warm idle. Cold idle sounds fine, warm idle sounds diesely and the sound is definitely coming from the timing chain area. I have no idea if either of these could be related to Vanos issues.

https://www.dropbox.com/s/uf1tnorfvf...ected.MOV?dl=0

https://www.dropbox.com/s/rskud0kbiu...%20O2.MOV?dl=0

If a bad DME is indicated, I'm prepared to go new; I think there's an online source for about $800. Not inclined to take my chances with junkyard roulette at this point, although the DME does seem to be generally pretty robust. Thoughts?
Rarely is the DME bad.
armenh7 is offline   Reply With Quote
Old 11-21-2017, 12:05 PM   #20
aaalbedo
Registered User
 
Join Date: Apr 2016
Location: Gunbarrel CO
Posts: 49
My Ride: 2006 330 CIC
Thanks, that's what I thought. Same is true of the Fiat ECUs that are a minimum of 32 years old today.
aaalbedo is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON



All times are GMT -5. The time now is 10:40 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
(c) 1999 - VerticalScope Inc. All rights reserved.