E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 02-16-2011, 11:41 AM   #1
92luder
Registered User
 
Join Date: Sep 2010
Location: Erie, Pa
Posts: 108
My Ride: 01 BMW 330ci
Rain sensor problem

So I have been wanting to fix my rain sensor wipers so I ordered a used rain sensor off of ebay, but I noticed when I got it the sticky stuff on the lens is all messed up. I attached a picture of what it looks like. Is there anyway of attaching this to my windshield and making it work or should I try sending it back? I wish I could take the guts from this one and use the lens on the car but when I took them apart it seems like they are together.
Attached Thumbnails
Click image for larger version

Name:	IMG_20110216_123302.jpg
Views:	111
Size:	122.0 KB
ID:	393487  
92luder is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-16-2011, 12:57 PM   #2
briangl92
Registered User
 
Join Date: Apr 2010
Location: Scotts Valley
Posts: 9,515
My Ride: A08 ZSP ZPP SULEV
I had my windshield replaced and I was asking the tech at the shop about it. He says they come from the factory bonded to the windshield. I'm not sure a DIY replacement is possible - it sounded like removing it would basically destroy it.
briangl92 is offline   Reply With Quote
Old 02-16-2011, 03:50 PM   #3
92luder
Registered User
 
Join Date: Sep 2010
Location: Erie, Pa
Posts: 108
My Ride: 01 BMW 330ci
Well I ran into another problem. I put the new rain sensor on the old lens that was on the windshield and the wipers just wipe like crazy, but when I take it off it acts normal and when I wave my hand in front of it the wipers work. So does this mean I need to take the lens off the the windshield and reapply it with silicon since I had like one small bubble in it?
92luder is offline   Reply With Quote
Old 02-18-2011, 01:17 PM   #4
briangl92
Registered User
 
Join Date: Apr 2010
Location: Scotts Valley
Posts: 9,515
My Ride: A08 ZSP ZPP SULEV
I'm not 100% sure but I'm guessing a bubble would mess with it. You could take it to a glass shop and they'd know more about it.
briangl92 is offline   Reply With Quote
Old 02-18-2011, 05:32 PM   #5
iansanderson
Registered User
 
Join Date: Feb 2009
Location: Northeast Ohio
Posts: 2,778
My Ride: 2001 330CiC
ok.. there's quite a few issues going on here. First of all, the rain sensor for the E46 doesn't glue/attach directly to the windshield.. the mount does. The mount contains the focusing optics for the rain sensor (and light sensor if manufactured after 09/01).

So, have you completely removed your mount from the windshield? If so, you will need to clean all of the glue from it, and reattach it. Then, you will need to verify that is the correct rain sensor for an E46, clean all of the goop off of it and re-attach it to the mount which is done without glue.

Finally, depending on what kind of car the used Rain Sensor was removed from, it may need coded to your car. BMW used two different wiper park systems that the rain sensor interfaces directly with. If the car the used sensor came from uses the different system, this can cause the wipers to stay on all the time. Also, a used sensor should be "initialized" to your windshield or else it may not work correctly.

here is a great write-up on re-attaching the RLS mount to the windshield.

http://forum.e46fanatics.com/showthread.php?t=615032
__________________



Cheat Sheet:

GT1/ISIS/MoDiC = Factory authorized diagnostic system used by BMW dealerships across the world.

NCS Expert = BMW Factory R&D programming tool available on the internet (not intended for the public and not available to the dealership network)

OEM = Genuine BMW part only available from a franchised BMW dealership.

DME = Engine Management Computer

Last edited by iansanderson; 02-18-2011 at 05:34 PM.
iansanderson is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 08:27 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use