E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 08-28-2010, 08:58 AM   #1
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
DSC and brake warning lights come on and go

hi guys! here is my problem
DSC and brake warning lights come on after few miles of driving after first engine start, it remains on all thoughout the day. After parking it overnight, and starting the engines the following day, I DON'T get the lights to come on! but goes ON again after few miles of driving! and so on and on and on! i had the codes red! "pressure sensor" is what came out! my mechanic told me that you have to buy the whole module because they don't sell pressure sensors alone.

I just have few questions.....

1. what is the problem?
2. do i need to have these fixed right away? i mean these are just added features or percs of owning a bimmer but in a normal car these features aren't available right? i mean the car would still function and run normally even if these DSC and brake warning lights are on right?
3. what is the danger ? my DSC and traction controls are inoperative?


THANKS A LOT E46 FANATICS! you guys ROCK! hope you can help me! THANKS AND GOD BLESS!

Last edited by captainsatch; 08-28-2010 at 09:12 AM.
captainsatch is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 08-28-2010, 09:01 AM   #2
alwaysbored786
Registered User
 
Join Date: Apr 2009
Location: Fairfax, Va
Posts: 5,784
My Ride: Noble|M3|XJ
when those lights are on, your dsc is totally disabled, meaning you have full control of the car...drive carefully.

I had this same exact issue, and it went away by its self (dont ask me how). I got the codes read, and it said steering wheel position sensor was off, and i figured it went bad.

Read the codes on your car, it could be same sensor as mine, or a wheel speed sensor, or something else.
__________________

*NO F-BOMBS IN SIGS*
How to refinish rims
Quote:
Originally Posted by Coldintake View Post
I am proposing opening up a Paypal fund for OP. The funds will directly be used in purchasing a farm so that OP can grow some balls.
alwaysbored786 is offline   Reply With Quote
Old 08-28-2010, 09:13 AM   #3
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
Quote:
Originally Posted by alwaysbored786 View Post
when those lights are on, your dsc is totally disabled, meaning you have full control of the car...drive carefully.

I had this same exact issue, and it went away by its self (dont ask me how). I got the codes read, and it said steering wheel position sensor was off, and i figured it went bad.

Read the codes on your car, it could be same sensor as mine, or a wheel speed sensor, or something else.
I had the codes read! I got a an error of " pressure sensor."
captainsatch is offline   Reply With Quote
Old 08-28-2010, 10:16 AM   #4
alwaysbored786
Registered User
 
Join Date: Apr 2009
Location: Fairfax, Va
Posts: 5,784
My Ride: Noble|M3|XJ
Quote:
Originally Posted by captainsatch View Post
I had the codes read! I got a an error of " pressure sensor."
yea i dont know wtf that is. Research it up a bit, hopefully you dont need a new module, if you do, your gonna be shelling out a lot of money.
__________________

*NO F-BOMBS IN SIGS*
How to refinish rims
Quote:
Originally Posted by Coldintake View Post
I am proposing opening up a Paypal fund for OP. The funds will directly be used in purchasing a farm so that OP can grow some balls.
alwaysbored786 is offline   Reply With Quote
Old 08-28-2010, 10:18 AM   #5
Solidjake
Zero. Oil. Leaks.
 
Solidjake's Avatar
 
Join Date: May 2008
Location: NYC
Posts: 21,862
My Ride: 2002 330i
What was the code number
Solidjake is offline   Reply With Quote
Old 08-28-2010, 12:28 PM   #6
Levim9
Registered User
 
Join Date: Sep 2006
Location: Central PA
Posts: 2,017
My Ride: S54 325i
Have you had an alignment in a while? My traction system acted just like yours until I got an alignment done. I'm not saying that will fix it but it's worth looking into.

What was the code number you got?
__________________


Slicktop - S54 - 6MT - 3.62 LSD - Active Tuned - JVT Headers - TMS Tracksport Coils - Hotchkis M3 Swaybars
Levim9 is offline   Reply With Quote
Old 08-28-2010, 03:12 PM   #7
motormadness
Registered User
 
Join Date: May 2009
Location: IL
Posts: 76
My Ride: 330CI
I had/have this issue. I didn't have the DSC codes read. I have found that if i turn the wheel full deflection to the left and then right, then let the car sit for a while, then the lights don't come on for about 50 to several hundred miles. I don't know what it is. Most of my driving lately has been less than 10 miles, so it hasn't really come on at all.
motormadness is offline   Reply With Quote
Old 08-28-2010, 05:27 PM   #8
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
thanks guys for all your replies!
i can't remember the code number, will have it checked again! my question is if I just leave the way it is, would it result in any damage in my car? I mean it's just the DSC traction control that wouldn't work right? but i'd still be able to drive and run my car normally. Thanks guys thanks! really appreciate it!
captainsatch is offline   Reply With Quote
Old 08-29-2010, 01:34 AM   #9
Levim9
Registered User
 
Join Date: Sep 2006
Location: Central PA
Posts: 2,017
My Ride: S54 325i
It probably won't hurt anything but you should find out what is causing it to not work. If your alignment is off and causing your traction control to not work like in my experience, you should get it taken care of.
__________________


Slicktop - S54 - 6MT - 3.62 LSD - Active Tuned - JVT Headers - TMS Tracksport Coils - Hotchkis M3 Swaybars
Levim9 is offline   Reply With Quote
Old 08-29-2010, 09:10 AM   #10
bAby norAA
Registered User
 
Join Date: Feb 2010
Location: Vermont
Posts: 507
My Ride: 01 BMW 330i
there is a lot of potential problems that could cause ur dsc control module not to work properly. easiest thing would be to bring it to someone who can read the values of your speed sensors/check for other hidden codes that normal obd II code readers can not see.

it may be as simple as getting a proper 4 wheel alignment. but without a proper scan you will be stabbing in the dark.
__________________

| VF Supercharged Stage 1.5| Southbend Stage 2 Clutch | ZHP Cams | Technik Headers |
bAby norAA is offline   Reply With Quote
Old 08-29-2010, 09:17 AM   #11
c5ry
Registered User
 
Join Date: May 2008
Location: Philly, Pa
Posts: 130
My Ride: 2011 M3
IM having about the same problem, dsc, brake and tire light are orange. they all come on after i had a back tire blow out on me.
c5ry is offline   Reply With Quote
Old 08-29-2010, 10:03 AM   #12
Adam330i
Registered User
 
Join Date: Jun 2009
Location: Pewaukee, WI
Posts: 335
My Ride: 03 M3
I called the dealership about this problem in the past they told me it was more than likely the wheel speed sensor. I never fixed the issue because it would come and go. The dealership said it wasn't something to be to concerned about they said my DSC was still enabled. How true that is I'm not sure!! It is the stealership!!!
Adam330i is offline   Reply With Quote
Old 08-29-2010, 07:45 PM   #13
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
thanks guys for your replies! really appreciate it, my only concern is is it gonna affect my car's basic role, I mean would i still be able to drive my car normally even if i dont have the DSC fixed? it's just an added feature in BMWs right? a lot of cars dont have this feature. of course i'd lose all those cornering braking control and traction, Dynamic Stability Control feature!
thanks guys!
captainsatch is offline   Reply With Quote
Old 09-12-2010, 12:59 AM   #14
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
it went on again after a few weeks of driving! lights came back after driving it for weeks. total miles i added in my odometer was around 300miles. it went away again after i turned the engine off and drove the next day! guys what's gonna be the danger with my car if i don't have this fixed? i mean i'd still be able to drive my car under NORMAL conditions even if the DSC and brake lights are on right? I'd just lose the traction control features but when it comes to driving it it would nott really give me a headache right? had the codes read and i got a PRESSURE SENSOR error, my mechanic told me it might be a faulty dsc module, thanks guys! would i still be able to use my car and drive it normally? i understand the DSC is an added feature of bmw for tight cornering turns and traction controls. my other japanese car doesnt have this feature so i dont really mind if i would not have this in my e46. thanks for the help guys!
captainsatch is offline   Reply With Quote
Old 09-12-2010, 12:29 PM   #15
hawk99
Registered User
 
Join Date: Apr 2006
Location: Victoria
Posts: 214
My Ride: 323ci
Take the time to take your wheel speed sensors out and clean them, and reinstall. Very easy, and may clear up you problem with no $$$$.
hawk99 is offline   Reply With Quote
Old 09-12-2010, 06:04 PM   #16
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
how do i clean those sensors sir? thank you
captainsatch is offline   Reply With Quote
Old 09-15-2010, 05:29 AM   #17
captainsatch
Registered User
 
Join Date: Jan 2009
Location: Philippines
Posts: 52
My Ride: 2000 BMW 316i
had the codes read! got 5e21 pressure sensor! its the sensor in the brake master cylinder! 34521164458 is the part number! shop is charging me $200 just for the sensor! labor excluded !
captainsatch is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use