E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 1 votes, 5.00 average. Display Modes
Old 01-07-2009, 07:44 PM   #1
Titanium3Series
Registered User
 
Join Date: Oct 2007
Location: ATL, Georgia
Posts: 276
My Ride: 03 325,97Max,02Gsxr
Why is my traction control and brake light on?

I was wonder why my traction control and emergency brake in yellow light on? I just got done replacing my idler pulley, put everything back on and started the car to drive and now these lights are on. I did not disconnect anything exept for my MAF, and the the plug on the radiator shroud. WHat could this be?
__________________

l 2003 BMW 325i l 1997 Nissan Maxima l 2002 GSXR Telefonica l
Titanium3Series is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-07-2009, 07:45 PM   #2
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
speed sensor?
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-07-2009, 07:45 PM   #3
GRIDLOCK
Registered User
 
Join Date: May 2006
Location: OC
Posts: 2,281
My Ride: E36 / E46
Go get codes pulled.
__________________

Have an EVAP code? Replacing gas cap did not fix? Give me a holler, I can do a smoke test for ya.
GRIDLOCK is offline   Reply With Quote
Old 01-07-2009, 07:57 PM   #4
wasp9166
ima touching member
 
wasp9166's Avatar
 
Join Date: Dec 2007
Location: straight out da bronx
Posts: 5,259
My Ride: 04 330i jet black
Send a message via Yahoo to wasp9166
why would his dsc lights throw a code?
__________________

"if polarity comes from protons, does morality come from morons?"

Quote:
Originally Posted by russ330 View Post
"Mommy and Daddy are getting a divorce now because wasp9166 had to piitb with Mom."
wasp9166 is offline   Reply With Quote
Old 01-07-2009, 07:58 PM   #5
GRIDLOCK
Registered User
 
Join Date: May 2006
Location: OC
Posts: 2,281
My Ride: E36 / E46
Quote:
Originally Posted by wasp9166 View Post
why would his dsc lights throw a code?
Because they do.
__________________

Have an EVAP code? Replacing gas cap did not fix? Give me a holler, I can do a smoke test for ya.
GRIDLOCK is offline   Reply With Quote
Old 01-07-2009, 08:05 PM   #6
ahull
Registered User
 
Join Date: Jun 2007
Location: Charlotte, NC
Posts: 76
My Ride: 2003 330i
Surprisingly (or maybe not but it doesn't make sense to me), a fault in your intake readings can cause this. Make sure all the contacts on the MAF plug are clean and there's no damage and that all the intake connections are tight. Then get your codes reset.

I had the same codes/lights/limp mode from a leaky intake pipe and just tightened everything up and it was fine.
ahull is offline   Reply With Quote
Old 01-07-2009, 08:06 PM   #7
ProchaineStation
Registered User
 
Join Date: Oct 2008
Location: Montreal, Canada
Posts: 4,208
My Ride: Metro, Bus, Bike
Send a message via MSN to ProchaineStation
maby u turned of traction and stability control off

did u press and hold the dsc button?
__________________
Next Stop: ProchaineStation™

Montreal, world transit & infrastructure enthusiast.
www.youtube.com/AntoDamicoShow
ProchaineStation is offline   Reply With Quote
Old 01-07-2009, 08:25 PM   #8
Titanium3Series
Registered User
 
Join Date: Oct 2007
Location: ATL, Georgia
Posts: 276
My Ride: 03 325,97Max,02Gsxr
Quote:
Originally Posted by Bmwclubofquebec View Post
maby u turned of traction and stability control off

did u press and hold the dsc button?

Nope I did not do that, plus I have pressed it cause I tried to try turn it off.

Where is the speed sensor, I did not mess aroundthe wheel At all. Also no CEL is on so no codes.
__________________

l 2003 BMW 325i l 1997 Nissan Maxima l 2002 GSXR Telefonica l

Last edited by Titanium3Series; 01-07-2009 at 08:28 PM.
Titanium3Series is offline   Reply With Quote
Old 01-07-2009, 10:27 PM   #9
//TRD power
Registered User
 
Join Date: Jun 2008
Location: Zero Maintenanceville
Posts: 2,561
My Ride: 3.0 | 200hp | 214trq
check your brake fluid level
__________________
//TRD power is offline   Reply With Quote
Old 01-07-2009, 10:29 PM   #10
00bmw323
Registered User
 
Join Date: Mar 2008
Location: Killa4nia
Posts: 4,062
My Ride: 00 323/91 integra RS
did u jack up the car anywhere?
__________________

-Jorge
All low no go
00bmw323 is offline   Reply With Quote
Old 01-07-2009, 10:34 PM   #11
LABMW13
Registered User
 
Join Date: Dec 2007
Location: Columbus Ohio
Posts: 477
My Ride: M3, 330i, '89 325i
There is something wrong with your traction control system, who knows what caused it though
__________________

M3: SSR GT3 Wheels, H&R Coilovers, JL 12" W6, Eisenmann 83mm, SS Headers, 4.10's, CF CSL Trunk & Diffuser, Euro Front Bumper, Hamann CF front lip, 3000k Fogs, NX 125 Shot
UUC Parts: SSBC Brakes, Lines, Sway bars, 8LB Flywheel, twin disc clutch, Evo 3 Shifter, RK7A Shift Knob, CF E-brake, Rasp-X Mid Pipes
Coming Soon: VRS Vented Race Hood & VCSL CF Roof Panel
LABMW13 is offline   Reply With Quote
Old 01-07-2009, 10:49 PM   #12
kosnosferatu
Registered User
 
Join Date: Oct 2004
Location: Madison, WI
Posts: 108
My Ride: 2000 323ci
this used to happen to me too, and for me getting a new battery fixed it. perhaps that might be it?
kosnosferatu is offline   Reply With Quote
Old 01-08-2009, 12:03 AM   #13
Titanium3Series
Registered User
 
Join Date: Oct 2007
Location: ATL, Georgia
Posts: 276
My Ride: 03 325,97Max,02Gsxr
my brake fluid level is perfect, and the battery is about 2 months old and has not caused any problem so far. Does anyone have a diagram or picture of the speed sensors? Maybe i knocked something loose when i was putting the plastic undertray on.
__________________

l 2003 BMW 325i l 1997 Nissan Maxima l 2002 GSXR Telefonica l
Titanium3Series is offline   Reply With Quote
Old 01-08-2009, 11:04 AM   #14
justdru
Registered User
 
Join Date: Sep 2006
Location: VA
Posts: 45
My Ride: BMW 330ci
Quote:
Originally Posted by ahull View Post
I had the same codes/lights/limp mode from a leaky intake pipe and just tightened everything up and it was fine.
Bump. This fixed the exact same issue for me... I have no idea why either.
justdru is offline   Reply With Quote
Old 01-08-2009, 11:26 AM   #15
Titanium3Series
Registered User
 
Join Date: Oct 2007
Location: ATL, Georgia
Posts: 276
My Ride: 03 325,97Max,02Gsxr
Well I tightened everything up, so we will see, I hve not had the chance to drive it to see if it will clear. I started it up and the lights gave not gone off yet. Also I notice that is turns on with the car, opposed to comming on when the car starts moving like I have seen.

Thanks everyone for helping me out and throwing Ideas out there.
__________________

l 2003 BMW 325i l 1997 Nissan Maxima l 2002 GSXR Telefonica l

Last edited by Titanium3Series; 01-08-2009 at 11:40 AM.
Titanium3Series is offline   Reply With Quote
Old 01-08-2009, 11:49 AM   #16
ferrarix99
Registered User
 
ferrarix99's Avatar
 
Join Date: Oct 2005
Location: Wayne, New Jersey
Posts: 3,294
My Ride: 87 325e - 05 M3 Vert
Quote:
Originally Posted by k7780446 View Post
speed sensor?
__________________
click for pics of the old ride...
-Nick the Greek-
euro.techniks
Bimmerworld Epic Tune | OEM Euro Headers | CSL Brakes | B&B TriFlo | aFe SuperStock | PSS10 | Varrstoen TE37 | V1 | ZKW Lens Swap | Orion Golds
Want your car coded? PM me.
ferrarix99 is offline   Reply With Quote
Old 01-08-2009, 12:00 PM   #17
wasp9166
ima touching member
 
wasp9166's Avatar
 
Join Date: Dec 2007
Location: straight out da bronx
Posts: 5,259
My Ride: 04 330i jet black
Send a message via Yahoo to wasp9166
so if i were to hook up my peak , turn off dsc, even tho ses light is not on, it would read a code? or only if it turns off by itself?
__________________

"if polarity comes from protons, does morality come from morons?"

Quote:
Originally Posted by russ330 View Post
"Mommy and Daddy are getting a divorce now because wasp9166 had to piitb with Mom."
wasp9166 is offline   Reply With Quote
Old 01-08-2009, 12:07 PM   #18
jbeurotech
Regional Sponsor
 
Join Date: Aug 2006
Location: New Brighton MN
Posts: 5,019
My Ride: 2000 E46 with 254K
Sorry Cystal ball is broek and I lost my magic turban.... Get the codes read in the ABS DSC only way you will know whats wrong. A maf can set a DSC codes as the DSC needs to see a load input over can from the DME to calculate slip rate and traction control. Primary load signal comes from the Maf.
__________________

Seth Thorson
Service Manager/BMW Tech
JB Eurotech Service "Your Reasonable Dealer Alternative"

General Questions can be sent to appointment@jbeurotech.com

1. Do not argue with an idiot. He will drag you down to his level and beat you with experience.
2. Light travels faster than sound. This is why some people appear bright until you hear them speak.
jbeurotech is offline   Reply With Quote
Old 04-11-2009, 11:01 PM   #19
Titanium3Series
Registered User
 
Join Date: Oct 2007
Location: ATL, Georgia
Posts: 276
My Ride: 03 325,97Max,02Gsxr
well i found my problem. My lights came on after i replaced my fan blade. Well looking around the other day i relized that the fan shroud was on 100% bolted down. I put a plastic clip where i metal screw should have gone, on the passenger side at the top of my fan shroud. I put this bolt back on, just take it right now even thinking it had anythign to do with the DSC, and when i drove my car after that the lights went off......i dunno, why that screw mattered, but i dont care cause the lights are off not
__________________

l 2003 BMW 325i l 1997 Nissan Maxima l 2002 GSXR Telefonica l
Titanium3Series is offline   Reply With Quote
Old 04-11-2009, 11:15 PM   #20
Acarder
Registered User
 
Join Date: Feb 2009
Location: United States
Posts: 4,656
My Ride: 69' M3
Quote:
Originally Posted by Titanium3Series View Post
well i found my problem. My lights came on after i replaced my fan blade. Well looking around the other day i relized that the fan shroud was on 100% bolted down. I put a plastic clip where i metal screw should have gone, on the passenger side at the top of my fan shroud. I put this bolt back on, just take it right now even thinking it had anythign to do with the DSC, and when i drove my car after that the lights went off......i dunno, why that screw mattered, but i dont care cause the lights are off not
That doesn't sound like it would have caused the problem... theres a possibility that the lights are turning off intermittently and theres still a problem.
Acarder is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 02:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use