E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-02-2009, 07:20 PM   #1
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
help me with problem!!

so when im driving everything will be fine until i hear a "beep" and then my EML light turns on yellow, then my traction control and brake light come on yellow

if i shut off the car for a sec and then restart the car it all goes away and doesnt come on for a while, but sometimes it comes back within a few minutes.

it doesnt go into limp mode, the only different is when i let off the gas it kind jolts right when i let off and then is it.

(video taken by phone sorry bad quality)

here is a video showing the lights
car is in 4th when accelerating

the check engine light isnt related (bad intake boot)
airbag light needs to be reset i know!!

really only things im askin about is my EML, Traction Control, and Brake light.


and the alarm in the back round is my v1 being dumb (it rings some times when i hit the gas some what hard.)

any ideas??

I KNOW MY DASH LOOKS LIKE A CHRISTMAS TREE!!

thanks for any help ahead of time!!

__________________
5492_121783803182_586518182_2342960_2124492_n

Last edited by k7780446; 01-02-2009 at 07:42 PM.
k7780446 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 01-02-2009, 09:01 PM   #2
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
bump
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-02-2009, 09:03 PM   #3
//TRD power
Registered User
 
Join Date: Jun 2008
Location: Zero Maintenanceville
Posts: 2,561
My Ride: 3.0 | 200hp | 214trq
did you check for codes?
__________________
//TRD power is offline   Reply With Quote
Old 01-02-2009, 09:06 PM   #4
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
ya it is just to lean bank 1 and 2


its not related to the three lights (EML, Traction, and Brake light)

half the time when the SES light is off the three lights come on and the SES light never comes on.....so the three lights arent throwing any codes
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-02-2009, 09:10 PM   #5
//TRD power
Registered User
 
Join Date: Jun 2008
Location: Zero Maintenanceville
Posts: 2,561
My Ride: 3.0 | 200hp | 214trq
lol with your cluster looking the way it is, I would highly recommend a visit to the shop. I'm thinking one of your sensors are out of wack, but that's aa guess though so don't take my word for it. The traction and brake lights are mostly triggered by faulty sensors at the wheels.
__________________

Last edited by //TRD power; 01-02-2009 at 09:12 PM.
//TRD power is offline   Reply With Quote
Old 01-02-2009, 09:11 PM   #6
BodyMan
Registered User
 
Join Date: Jun 2007
Location: Straight outa Lowcash
Posts: 1,971
My Ride: 2002 325i
Speed sensor? ABS unit? I think that the 3 light combo is the combo of doom.

P.S. Did Santa put presents under your car this year? Sorry, I had to.
BodyMan is offline   Reply With Quote
Old 01-02-2009, 09:20 PM   #7
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
haha nice santa joke!

ya guys its bad....

but here is the good

airbag light..(easy fix just reset(need to get some free time to reset it lol)
SES light (banks 1 & 2 running lean....aka intake boot leak, need to order a new one(easy fix)

only thing left is the three lights... it doesnt effect my driving really at all though and goes away everytime i shut off the car....


it really looks worse then it is!! about 99% of the time the only light on is the airbag light haha but the video shows my car at its worst!
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-02-2009, 09:46 PM   #8
zuggerat
Registered User
 
Join Date: Sep 2007
Location: NJ
Posts: 375
My Ride: 05 ZHP, 75 911s
Send a message via AIM to zuggerat
I would take it to a shop to have it looked at when you get a chance. But I only say that because I'm not mechanically inclined enough to troubleshoot these things myself. Regardless, I like to have peace of mind, if I was getting lights all over the place it would bother me to no end. Let us know how it goes if you decide to bring it in.
zuggerat is offline   Reply With Quote
Old 01-02-2009, 10:34 PM   #9
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
hey thanks for the words man

ya i might end up takin it in but as of now money is tight im gonna try and trouble shoot the cheap stuff (cleaning the MAF, a valve one member thought caused this.)

if i cant fix it i guess mechanic here i come haha

thanks for the help guys!
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-02-2009, 11:00 PM   #10
BodyMan
Registered User
 
Join Date: Jun 2007
Location: Straight outa Lowcash
Posts: 1,971
My Ride: 2002 325i
I know some of your problems are not related, but I would start by fixing your known issues, intake boot and such. Just to start eliminating stuff. As sensitive as these cars can be, you never know what problems might clear themselves up.
BodyMan is offline   Reply With Quote
Old 01-02-2009, 11:34 PM   #11
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
ya true

ill get on it!
it really kills me seein my car in this shape
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-02-2009, 11:46 PM   #12
ejamin73
Registered User
 
Join Date: Jul 2008
Location: The Enchantment Island
Posts: 1,646
My Ride: '04 325i Sport Pkg
Sorry for the thread jack, but,
How do you reset the airbag light?
__________________




I just can't imagine the world without the smell of burned gas coming out of a well tuned engine:drool:
Quote:
Originally Posted by zhp pilot View Post
nice try on the sig you tard. unfortunately, when you click the link you see the actual quote.

you are on a roll with the FAIL tonight. :lmao:
ejamin73 is offline   Reply With Quote
Old 01-02-2009, 11:48 PM   #13
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
you need a separate tool

you can find them at most auto body shops and even a local mechanic could have one...or you could buy your own from bimmertools (i think that's the sponsors name on here)
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-02-2009, 11:53 PM   #14
ejamin73
Registered User
 
Join Date: Jul 2008
Location: The Enchantment Island
Posts: 1,646
My Ride: '04 325i Sport Pkg
__________________




I just can't imagine the world without the smell of burned gas coming out of a well tuned engine:drool:
Quote:
Originally Posted by zhp pilot View Post
nice try on the sig you tard. unfortunately, when you click the link you see the actual quote.

you are on a roll with the FAIL tonight. :lmao:
ejamin73 is offline   Reply With Quote
Old 01-02-2009, 11:56 PM   #15
k7780446
Registered User
 
Join Date: Dec 2007
Location: Portland Oregon
Posts: 1,923
My Ride: 323i
__________________
5492_121783803182_586518182_2342960_2124492_n
k7780446 is offline   Reply With Quote
Old 01-15-2009, 12:47 PM   #16
iaknown
Registered User
 
Join Date: Jan 2008
Location: nj
Posts: 51
My Ride: 2001 330i
I have the same problem, from research I've been doing and the engine codes on my car I'm trying to eliminate, it looks like you shouldn't even worry about the DSC lights and concentrate on fixing your engine codes. I know I currently have a bad O2 which is setting several codes, the same as yours, and ever since the codes I've had the DSC lights too....
iaknown is offline   Reply With Quote
Old 01-15-2009, 01:21 PM   #17
Team_Persia
Registered User
 
Join Date: Oct 2007
Location: San Diego, CA
Posts: 4,972
My Ride: '05 ZHP 'Vert - SOLD
Quote:
Originally Posted by BodyMan View Post
Speed sensor? ABS unit? I think that the 3 light combo is the combo of doom.

P.S. Did Santa put presents under your car this year? Sorry, I had to.
lol, i think santa left him some coal under the hood this year
__________________
-Amir
Team_Persia is offline   Reply With Quote
Old 01-15-2009, 01:37 PM   #18
kamaqazi
Registered User
 
Join Date: Sep 2007
Location: MA
Posts: 1,045
My Ride: 00 328i
Send a message via AIM to kamaqazi
Quote:
Originally Posted by Team_Persia View Post
lol, i think santa left him some coal under the hood this year


i would say somethign to do with a speed sensor.
but im not a mechanic.
__________________
kamaqazi is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 01:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use