E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > Tuning & Tech > DIY: Do It Yourself

DIY: Do It Yourself
Post here to share or improve your wrench turning skills! All BMW E46 DIY tips, tales, and projects discussed inside. Learn to work on your car and know the right BMW parts you will need!

Reply
 
Thread Tools Search this Thread Rating: Thread Rating: 3 votes, 5.00 average. Display Modes
Old 10-07-2008, 10:45 AM   #1
blank1984
Registered User
 
Join Date: Mar 2008
Location: New Lenox, IL
Posts: 11
My Ride: 2000 323i Sedan
Send a message via AIM to blank1984 Send a message via Yahoo to blank1984
Unhappy Secondary Air Relay Location Help

Where is the relay for the secondary air system located and does it have a label? I've got a 2000 323i (production date is 9/99).

I've been searching on here and on google for a few days now. But, my impatience has led me to finally post for help. I've been dealing with an intermittent CEL for the secondary air pump. I got the Peake tool from Ken and have reset it several times. I even replaced the pump. The solenoid is working. And, the vacuum hose is brand new. This is my last hope before I turn to a federal offense and get the simulator for EBay headers (all respect, but it is illegal).

I'd like to get this fixed; so, my wife can drive it, while I go to Korea. If something else happens, it's not going to flash twice.

The airbag light's another story. My car is a rolling stereotype! Any help is greatly appreciated.
__________________
We are the music makers; and, we are the dreamers of dreams.
blank1984 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 10-11-2008, 12:01 PM   #2
Pianofxr
Registered User
 
Join Date: Aug 2008
Location: hudson valley,NY
Posts: 12
My Ride: 2000 323it 5spd, ++
relay location

I have a 9/98 production 323i sedan and my secondary air pump relay was up behind the fusebox under the glovebox. You have to remove the glovebox to get to it. Not too bad a job. Its the "salmon" colored one on the left. BTW all this is detailed in the Bentley Manual for the E46. Pick one up, its the best money you'll spend on the car.
Hope this helps
Pianofxr is offline   Reply With Quote
Old 10-22-2008, 03:35 PM   #3
blank1984
Registered User
 
Join Date: Mar 2008
Location: New Lenox, IL
Posts: 11
My Ride: 2000 323i Sedan
Send a message via AIM to blank1984 Send a message via Yahoo to blank1984
http://forum.e46fanatics.com/showthread.php?t=618471
__________________
We are the music makers; and, we are the dreamers of dreams.
blank1984 is offline   Reply With Quote
Old 10-23-2008, 02:47 PM   #4
blank1984
Registered User
 
Join Date: Mar 2008
Location: New Lenox, IL
Posts: 11
My Ride: 2000 323i Sedan
Send a message via AIM to blank1984 Send a message via Yahoo to blank1984
salmon relay fixed it!
__________________
We are the music makers; and, we are the dreamers of dreams.
blank1984 is offline   Reply With Quote
Old 10-26-2008, 05:48 PM   #5
glenpointe
Registered User
 
Join Date: Jan 2008
Location: Detroit
Posts: 45
My Ride: 325i
Quote:
Originally Posted by blank1984 View Post
salmon relay fixed it!
I have the same problem, but mine is intermittent. The relay seems working 50% of the time. I will make an effort to fix it soon.
glenpointe is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 07:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use