E46 BMW Social Directory E46 FAQ 3-Series Discussion Forums BMW Photo Gallery BMW 3-Series Technical Information E46 Fanatics - The Ultimate BMW Resource BMW Vendors General E46 Forum The Tire Rack's Tire Wheel Forum Forced Induction Forum The Off-Topic The E46 BMW Showroom For Sale, For Trade or Wanting to Buy

Welcome to the E46Fanatics forums. E46Fanatics is the premiere website for BMW 3 series owners around the world with interactive forums, a geographical enthusiast directory, photo galleries, and technical information for BMW enthusiasts.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E46Fanatics > E46 BMW > General E46 Forum

General E46 Forum
This is the place to get answers, opinions and everything you need related to your E46 (sedan, coupe, convertible and wagon) BMW!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 02-22-2012, 12:51 PM   #1
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
O2 sensor, Dme repair

Original thread:http://forum.e46fanatics.com/showthr...386&highlight=


Alright,

I figured something else was wrong cause i couldn't get voltage to the o2 sensor. So i looked the the plug for the o2 sensors that goes to the dme.


Then i was like hmm, let me look in the dme. This is what i found.




Anyone know where to get this fixed, or replaced?
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051

Last edited by darksideracer69; 02-22-2012 at 03:20 PM.
darksideracer69 is offline   Reply With Quote
Ads by Google

Guests, get your FREE E46Fanatics.com membership to remove this ad.
Old 02-22-2012, 01:16 PM   #2
shanneba
Registered User
 
Join Date: May 2008
Location: Indiana
Posts: 2,096
My Ride: 2003 330Ci
A couple of places I have run across on the net that might be able to help:

http://www.ecudoctors.com/

http://www.rmsonlinestore.com/main.sc
__________________
Join BMWCCA
Discounts on new and CPO cars.
Most Dealers offer a parts discount, BMP Design 10% off
shanneba is offline   Reply With Quote
Old 02-22-2012, 02:00 PM   #3
flashmeow
Banned User
 
Join Date: Apr 2008
Location: Dallas, TX
Posts: 2,220
My Ride: E30-E46-E90-E90M-F30
Let me give u some advice. My advice are nothing profound since it is all common sense stuff bit I want to cover the basic with you.

1-u need to find the reason why your dme pin was burnt. Is there a voltage spike is there a grounding issue or maybe a short somewhere.

Do this will be a huge headache but will save u time and money in the future.

Imagine buying a new dme and have the same problem happen again. Also, imagine your dme is repairable because the problem is currently minor but over time the problem will escalate and end up ruining your dme.

sent from HTC EVO
flashmeow is offline   Reply With Quote
Old 02-22-2012, 02:39 PM   #4
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Quote:
Originally Posted by flashtwosix View Post
Let me give u some advice. My advice are nothing profound since it is all common sense stuff bit I want to cover the basic with you.

1-u need to find the reason why your dme pin was burnt. Is there a voltage spike is there a grounding issue or maybe a short somewhere.

Do this will be a huge headache but will save u time and money in the future.

Imagine buying a new dme and have the same problem happen again. Also, imagine your dme is repairable because the problem is currently minor but over time the problem will escalate and end up ruining your dme.

sent from HTC EVO
Check the original thread.

This is not my car. But I have already found and fixed the issue that caused this.

Thanks

Sent from my SGH-T959V using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051

Last edited by darksideracer69; 02-22-2012 at 03:20 PM.
darksideracer69 is offline   Reply With Quote
Old 02-22-2012, 05:07 PM   #5
flashmeow
Banned User
 
Join Date: Apr 2008
Location: Dallas, TX
Posts: 2,220
My Ride: E30-E46-E90-E90M-F30
Quote:
Originally Posted by darksideracer69 View Post
Check the original thread.

This is not my car. But I have already found and fixed the issue that caused this.

Thanks

Sent from my SGH-T959V using Bimmer App
since it is hard to gather your tone of voice i will give you the benefit of the doubt and will not take your post offensively.

anyhow, what happened and what was the problem and solution? I read the orginal thread and no where was the solution posted. if you did indeed fix the problem then I think it is a good idea to update the thread and show us the fix so others can learn from your experience.

thanks
flashmeow is offline   Reply With Quote
Old 02-22-2012, 06:33 PM   #6
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Quote:
Originally Posted by flashtwosix View Post
since it is hard to gather your tone of voice i will give you the benefit of the doubt and will not take your post offensively.

anyhow, what happened and what was the problem and solution? I read the orginal thread and no where was the solution posted. if you did indeed fix the problem then I think it is a good idea to update the thread and show us the fix so others can learn from your experience.

thanks
Yea wasn't trying to be a jack ass or anything, sorry should have put a

The problem was that the wires for the o2 sensor had melted together.

The solution was to separate them, cut out the burnt part and put them back together.

I think I might have the owner take this to a computer repair place to see if they can fix this pin. I'm no expert in looking at circuit boards. But that's all I found when I looked.

Sent from my SGH-T959V using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 02-22-2012, 06:39 PM   #7
flashmeow
Banned User
 
Join Date: Apr 2008
Location: Dallas, TX
Posts: 2,220
My Ride: E30-E46-E90-E90M-F30
Quote:
Originally Posted by darksideracer69 View Post
Yea wasn't trying to be a jack ass or anything, sorry should have put a

The problem was that the wires for the o2 sensor had melted together.

The solution was to separate them, cut out the burnt part and put them back together.

I think I might have the owner take this to a computer repair place to see if they can fix this pin. I'm no expert in looking at circuit boards. But that's all I found when I looked.

Sent from my SGH-T959V using Bimmer App
wow. awesome troubleshooting skills and thanks for the update.
I wish the owner good luck and hopefully the repair is not expensive and at least repairable.

thanks again for the update
flashmeow is offline   Reply With Quote
Old 02-24-2012, 09:37 PM   #8
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Issue resolved.

What i ended up doing was telling the owner to take the dme to a computer repair place. They soldered the pins together. I didn't think that i was going to be that simple, but i put the dme back in the car, and turned it on. Everything works as it should. Car was running fine, and i confirmed the signal to the o2 sensor with inpa.

__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 02-24-2012, 09:42 PM   #9
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,851
My Ride: '99 328i 1.04646 mu
Nice little DME repair! I have to tell you that I wrote a post about how I'd probably try to solder together those burnt things in the DME...then I realized how stupid I'd sound if I told everyone what I'd try! That's actually amazing and I wonder how many DME and $$$ might have been saved if more knew how easy it might be to fix it. It's expensive!

Nice!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 02-24-2012, 10:29 PM   #10
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Lol, if you posted it I probably would have tried .

But this fix only cost 10$

Sent from my SGH-T959V using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 02-25-2012, 05:26 AM   #11
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,851
My Ride: '99 328i 1.04646 mu
Dark, I recall pretty well when I wrote up my post which I then deleted.

If it was someone else, I might've posted this crazy thought, particularly if it was a Fanatic I didn't care about! Since I know you and you're an alleged Internet friend of mine (I think you are anyway!), I thought that not only would this 'diy DME fix' sound stupid, but that there was a risk that you'd otherwise permanently damage an expensive part that might be salvageable by someone that knew what they were doing, or worse, that it'd appear to work, but not really work and end up doing harm to your engine.

As much as I like you, I like your motor more!

Anyway, it sounded like a stupid idea after I'd written it, especially since I was just making stuff up, so I had to delete it!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 02-25-2012, 07:52 AM   #12
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
Haha, I see that you are getting better at controlling your random thoughts.

Internet buddies

Sent from my SGH-T959V using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 02-25-2012, 08:15 AM   #13
flashmeow
Banned User
 
Join Date: Apr 2008
Location: Dallas, TX
Posts: 2,220
My Ride: E30-E46-E90-E90M-F30
Quote:
Originally Posted by darksideracer69 View Post
Haha, I see that you are getting better at controlling your random thoughts.

Internet buddies

Sent from my SGH-T959V using Bimmer App
LOL

Dmax...how old are you? I am asking because I want to prepare myself for the day that my husband reach a point where he will start rumbling off random thoughts.

honey what you want for dinner? chicken or beef?

him: "For seven years, Christopher Columbus traveled around Europe looking for someone who would finance his journey. The monarchs of Europe made fun of him, saying that it was too risky, and dangerous to attempt such a voyage around the globe but I want chicken please."
flashmeow is offline   Reply With Quote
Old 02-25-2012, 08:25 AM   #14
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,851
My Ride: '99 328i 1.04646 mu
Flash,

I won't ever really be able to tell you how old I am. I'm OCD and like to be accurate, and there's just no way to tell someone what my age is. The moment I write down a number, it'll be inaccurate...so I don't know how to answer that question.

And as for my random stuff...if you think that I'm bad, you should read some of your own posts! And I say this with all respect, as I'm a big lover of cats and F1 too!
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Old 02-25-2012, 08:28 AM   #15
flashmeow
Banned User
 
Join Date: Apr 2008
Location: Dallas, TX
Posts: 2,220
My Ride: E30-E46-E90-E90M-F30
Quote:
Originally Posted by dmax View Post
Flash,

I won't ever really be able to tell you how old I am. I'm OCD and like to be accurate, and there's just no way to tell someone what my age is. The moment I write down a number, it'll be inaccurate...so I don't know how to answer that question.

And as for my random stuff...if you think that I'm bad, you should read some of your own posts! And I say this with all respect, as I'm a big lover of cats and F1 too!
LOL. But Off Topic doesn't count. Outside of Off Topic I am very helpful, polite and classy

anyhow...to the OP...thanks again for the update and tip (bring to computer repair). Sorry for hijacking your thread. <---see how polite and well manner I am Dmax?
flashmeow is offline   Reply With Quote
Old 02-25-2012, 08:40 AM   #16
darksideracer69
Registered User
 
Join Date: Jan 2008
Location: TX
Posts: 2,886
My Ride: 01 325ci
It's all good. I lol'd

Sent from my SGH-T959V using Bimmer App
__________________
Quote:
Originally Posted by dmax View Post
If she ever yells 'oh god, oh god' just say, 'no, just Doug.'


IMAG02051
darksideracer69 is offline   Reply With Quote
Old 02-25-2012, 09:34 AM   #17
dmax
Registered User
 
dmax's Avatar
 
Join Date: Aug 2006
Location: NJ
Posts: 22,851
My Ride: '99 328i 1.04646 mu
Quote:
Originally Posted by flashtwosix View Post
LOL. But Off Topic doesn't count. Outside of Off Topic I am very helpful, polite and classy

anyhow...to the OP...thanks again for the update and tip (bring to computer repair). Sorry for hijacking your thread. <---see how polite and well manner I am Dmax?
But you know your helpful General Forum posts are tainted by your obvious discrimination against our Donkey/goat loving brothers. Although you didn't state so specifically, it seems to me that somehow you think that your love of cats is a purer, higher class love than those who might like other animals.

Although I myself have talked trash about our beagle-loving brethren and sistern, I'm really okay with them...just I don't think they ought to be publishing pictures on the Internet of their beagles is all. I shudder whenever I see a new post in the "Oh, how I love my dog" thread. It's gotten to the point that I just can't read that thread anymore. No mean?
__________________


Performing at the Comedy Cove--595 Morris Ave. Springfield NJ reservations 973 376-3840

A recent set Skip to 1:30
dmax is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Censor is ON





All times are GMT -5. The time now is 09:28 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use